3GS, 4.2.1, tethering now crap

Discussion in 'iPhone' started by 5683565, Nov 30, 2010.

  1. 5683565 Suspended

    Joined:
    Feb 18, 2006
    Location:
    Hong Kong
    #1
    Hey all,

    Anyone else having tethering problems with the iOS 4.2.1 update? I'm on Vodafone NZ, so the iPhone is fully unlocked and tethering is free (+3GB per month for no extra cost!).

    It will begin to tether, with some sort of connection (pretty slow though), and then it will crash/freeze the iPhone. From here it needs to be crashed to be reset. With previous versions of iOS it worked fine.

    J
     
  2. drjazz Guest

    #2
    I'm having the exact same behavior with my iPhone 4 on iOS 4.2.1 on voda NZ.

    I've only tried tethering with a windows xp laptop, though it only has iTunes 9. Am about to try upgrading to iTunes 10. Wondering if perhaps the tethering driver is out of date.
     
  3. dempson macrumors regular

    Joined:
    Jun 10, 2007
    Location:
    Wellington, New Zealand
    #3
    Same problem for me. I have an iPhone 3GS, also on Vodafone NZ. I'm using tethering most days of the week and it has sometimes locked up five or more times in a day. Very frustrating.

    As James noted, it started after I installed iOS 4.2.1.

    I've filed a bug report with Apple, but I expect someone else will have reported it already and mine will get closed as a duplicate.

    See also this Apple Discussions thread:

    http://discussions.apple.com/thread.jspa?threadID=2660823&start=0&tstart=0

    From there it seems to be affecting a range of iPhone models and some people have established it is not specific to Windows or Mac OS X, or the iTunes version or drivers it installs, just to the web sites you happen to access.

    Some pattern of TCP/IP traffic delivered via tethering seems to trigger the problem.
     
  4. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #4
    Awesome.

    One more reason for me to stick with 4.1. :p

    -- Nathan
     

Share This Page