3GS 4.3.3 Unlock Woes!

Discussion in 'Jailbreaks and iOS Hacks' started by Orbane, Aug 10, 2011.

  1. Orbane macrumors member

    Joined:
    Apr 28, 2010
    #1
    Hi there,

    Apologies if this post is lengthy.

    I own an iPhone 3GS (16GB) that was originally locked to the 'Orange' network. It's been running unlocked on 4.2.1 perfectly with iPad baseband for about 4-5 months now (I even had working GPS). However, yesterday I came across a problem. I noticed that I had no signal bars, yet my carrier was still displayed. I live in quite a high signal area, so this was new to me. Upon further inspection I discovered that I could not make/receive calls or SMS messages. After playing around I discovered that if I turn off all data (3G and Cellular Data) my phone displays 'No Service'. When they're turned on, I will either get a 3G or Edge Logo and 'O2-UK' displayed. Here's where the interesting part comes in. Turns out that I can use all my data fine. Even though it's reporting no bars, I still get the effects of a full 3G connection. I'm basically only able to use my data connection and nothing else.

    After ruling out my sim card by trying it in another phone, I began to search around for a solution. I am aware that upgrading to the iPad baseband is a huge risk. However when I received the phone it was my only option for an unlock. While many people have similar problems, I don't think i've seen one where only the data side of things is working.

    Whilst trying to restore my phone and repair this issue I ended up with a bricked phone, stuck in a DFU Loop. I tried almost every combination of redsn0w/Pwnage Tool/Greenpois0n/Custom Firmware possible. After hours of failed attempts, I was finally able to use redsn0w to put my phone into a pwned DFU mode, install the stock 4.3.3 firmware (with 1015 error ofcourse) and Jailbreak successfully (again, with redsn0w). I also used ultrasn0w to unlock after this however have exactly the same issue except now i'm on 4.3.3 rather than 4.2.1. Unfortunately I do not have an Orange sim to check that it's not hardware, but I find that unlikely as I look after this phone very carefully and my issue appeared out of nowhere.

    If anyone has experienced anything similar or has any suggestions, i'd be interested to hear.

    Thank you.
     
  2. Orbane thread starter macrumors member

    Joined:
    Apr 28, 2010
    #2
    Just obtained an Orange SIM in order to check the signal with the original carrier and have the same issue. I think it's fair to say it's the GSM Antennae. What's the likelihood that a genius would check the baseband of the phone in an Apple store? Is this even an issue?

    Failing this does anyone have any experience with repair services, specifically for the antennae. So far I have looked at:

    http://www.iphonerepairsfast.co.uk/Apple-IPhone-3GS/Antenna-IPhone-3gs.html

    http://www.i-phone-repairs.co.uk/apple-iphone-3gs-repairs/iphone-3gs-signal-no-service-repair.html

    Cheers.
     

Share This Page