3GS: Apps crash immediately after launching

Discussion in 'iPhone' started by colmaclean, Jul 16, 2009.

  1. colmaclean macrumors 68000

    colmaclean

    Joined:
    Jan 6, 2004
    Location:
    Berlin
    #1
    This issue has just reared its head on my 3GS.

    Some of my apps appear to crash while loading. When I launch one of those affected, I see their initial screen briefly before it disappears and I'm back on the main menu screen...

    I've tried rebooting and also syncing but this has made no difference... :(

    Any ideas?
     
  2. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #2
    After rebooting the next best thing is to try a restore. First try restoring from a backup, then if that fails restore as a new phone.
     
  3. Eric8199 macrumors 6502a

    Joined:
    Feb 27, 2009
    #3
    I had this problem on my iPod Touch before 3.0. The way I solved it was by deleting and reinstalling ONE of my apps. Through the app store, not by synching. When I did that, it fixed the problem. Then suddenly the problem stopped occuring.
     
  4. colmaclean thread starter macrumors 68000

    colmaclean

    Joined:
    Jan 6, 2004
    Location:
    Berlin
    #4
    Thanks for the tips. Think I'll try the app remove one before doing anything drastic!
     
  5. colmaclean thread starter macrumors 68000

    colmaclean

    Joined:
    Jan 6, 2004
    Location:
    Berlin
    #5
    Problem solved. :D

    Cheers, my man! :cool:
     

Share This Page