3GS battery, do I have a problem?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Eric8199, Jan 1, 2010.

  1. Eric8199 macrumors 6502a

    Joined:
    Feb 27, 2009
    #1
    Hey guys,

    So I'm noticing a bigger drop in my battery life on my iPhone 3GS recently. Currently I'm at 80% with 45m of usage and 2h, 27m of standby. Wifi is on, location services on, push on, everything else off. My usage has been internet only (twitter, facebook, and web browsing). Earlier today I was at 62% after one hour and one minute of usage and 1 hour and 2 minutes of standby. Same things on, just web browsing.

    Am I correct in assuming that I have an issue, or am I being paranoid about nothing? I have already cycled the battery to recalibrate it, and just did a restore this morning. I had also been having an issue where it would randomly drop 5-20% for no reason, but haven't had that issue since I restored (although it's only been a few hours since then).

    Can anyone tell me what they're getting with their iphones? I have an appointment Sunday at the Genius bar to hopefully get swapped out, but we'll see. If you guys think I'm crazy, I may cancel. Gonna be pushing it to get there on time probably.

    Thanks in advance.
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Push on could be a factor, but since you say it just started doing this recently, probably not. So, I'd say with that kind of drop in 45 minutes that you have a battery problem (and especially since you've calibrated and done a restore). One thing though, you have a prior iPhone that you restored from backup onto this 3GS? If so, you need to restore as new or reset all settings for the 3GS or that might be the cause of the battery issues.
     
  3. Eric8199 thread starter macrumors 6502a

    Joined:
    Feb 27, 2009
    #3
    Originally when I set my phone up, I restored from a backup from my iPod Touch. However, when I restored this morning, I set it up as a new phone.

    An update, I'm currently at 51% with 1h 48m of usage and 4h 44m of standby. Mostly web browsing and about 15 minutes of watching a video. I'm sure I've got a problem. I've always been kinda obsessed about the battery, so I'm well aware of the fact that this is a big decline from what I used to get.

    Only reason I have push on is for Find my iPhone and for my MobileMe e-mail. Location services is also on for Find my iPhone.

    Thanks for the help.
     
  4. Eric8199 thread starter macrumors 6502a

    Joined:
    Feb 27, 2009
    #4
    Went and saw the Genius today. New and shiny iPhone in my hands with no battery problem. Was simple, only took about 10 minutes. Very happy with my service. Although I had hoped to switch to white, but they said no.
     

Share This Page