3GS Battery Problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Lucbert, Jul 21, 2009.

  1. Lucbert macrumors regular

    Lucbert

    Joined:
    Dec 8, 2008
    #1
    Hey!
    I am having a problem with my iPhone 3GS.
    The battery indicator is acting very, very weird.
    It keeps changing.
    This morning my iPhone was 83% charged. I used this afternoon it showed 56% and a couple minutes later it suddenly showed 69% (I did not charge it I know that for a fact).
    After that I kept on using it until Battery was down to 39% and now it is suddenly showing 65% again.
    I really don't know what is wrong. Has that happened to anyone? I would really, really appreciate your help!
     
  2. AiralynRose macrumors 6502a

    Joined:
    Jun 3, 2008
    Location:
    Pittsburgh, PA
    #2
    Try restoring it. See if that fixes the problem.
     
  3. jeffames macrumors newbie

    Joined:
    Jul 23, 2009
    #3
    Same issue

    Well, I fell a bit better knowing that I'm not the only one. I watched my 3G S go from 20% to 7% while I was using it, set it aside for an hour, and when I picked it up I had 35% charge left. I'm taking it to the Apple store.
     
  4. dss macrumors member

    Joined:
    Jul 10, 2008
    #4
    Hi, I'm having the exact same problem. In the spirit of full disclosure, my phone is jail broken and I do have backgrounder installed, but I have been very careful not to activate it or any other heavy usage device. I've also been trying to soft reset the phone by using the power off/home trick from time to time.

    Anyway, my 3gs has been running fine since day one. Yesterday I took it from a full charge is was down to 50% almost in an hour of standby. I tried powering on and off as well with no luck. The indicator is going haywire, jumping up, then down, etc... so I let it drain all the way down (and it did shut down much quicker than normal so the battery is listening to the indicator) and gave it a fresh charge and now I'm having the same issues once again.

    I'd welcome any and all ideas as I'd really prefer not to start fresh with a new restore if possible as I've spent a lot of time getting this device just the way I want it, but I guess I will if I have to.

    Thanks!
     
  5. 3587 macrumors 6502a

    Joined:
    Mar 23, 2008
    #5
    Same here! I just fixed my WiFi issue, now the battery indicator is all over the map! This OS is the worst!
     
  6. wolvesboy macrumors newbie

    Joined:
    Jun 20, 2009
    #6
    Had my 3GS since it came out. Had no battery issues since the first couple of days when I really hammered the usage!

    But from it has died on me yesterday and today on both occassions going from 100% to 0 and shutting down in about 5 hours. It almost seems as though something on the phone is running but I don't know what. I've done all the usual things - turned off 3G, turned off location services, turned of bluetooth etc but problem seems to remain. At one stage today I turned off the phone with about 8 % left so that I could use what little juice was left to make a call later - but it wouldn't start up - so it felt like the battery was further drained even when off!

    I'm recharging now and see what tommorow brings but other than that it looks like a trip to see a genius.
     

Share This Page