3GS - "Call failed/ended" within 15-60 seconds

Discussion in 'iPhone' started by cosmichobo, Oct 17, 2011.

  1. cosmichobo macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #1
    G'day

    So, last weekend I became an iPhone owner. 3GS model. I was given a brand new 3G SIM card to use with it, as my old SIM was old... :)

    Since getting the phone, I've found how fun it is... yay.

    But, as a phone, so far, it sucks.

    I can rarely have a call last more than 1 minute... whether dialed or received... they all end up as "Call failed" or "Call ended".

    This happens in my home, in the car, at the park, at work... ie it shouldn't just be Optus' network issues... probably.

    I just tried to call Optus for help (3 times to get far enough along in the conversation to be told I was in a 20 minute queue), but of course then it died again.

    Meanwhile... what can I try? Is it a dud phone?

    Cheers


    cosmic
     
  2. moel macrumors 6502

    Joined:
    Nov 7, 2007
    #2
    Reset your network settings

    Pray

    to be honest i'd guess at a duff sim, rather than a duff phone.

    Take the sim out give it a rub and pop it back in, see what happens.
     
  3. caazz macrumors newbie

    Joined:
    Aug 10, 2011
    #3
    It could be a dud phone or it could be Optus. I also have a 3GS with Optus and I had the same issue as yourself. If you speak to Optus, they will tell you to have the sim swapped to cancel out the fact that it might be the sim card. (I did that and still had the same issue). I was also told reset the phone and start from new phone and still had the same issue.

    Finally, I made an appointment with the genius bar and they checked some stuff then swapped the phone for me. Since getting the 'new' refurbished phone I haven't had that problem anymore. Sure, I get it every now and then but it only happens infrequently and now I can use my phone as a phone which is very exciting for me :p

    But a friend of mine had really bad service (on a Samsung Galaxy S) and all Optus told her to do was to turn off 3G and make a call then turn it back on to use the internet so she swapped to Telstra.... So who knows about Optus?

    Try the sim swap, reset, genius bar appointment thing and at least one of these should work for you! :)
     
  4. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #4
    Ah... sounds like it could be an interesting trip then...

    Eventually spoke to someone from Optus, and they cleared some prefs at their end (noting nothing unusual) and had me reset the phone.

    (In fact, when I held the power and home buttons, the phone did not auto restart/hard reset... it just asked if I wanted to turn it off... and/or started voice control... and/or took a screenshot - Eventually the lady just got me to turn the phone off for 15 seconds...)

    We tried another Optus sim card (from my wife's phone), and the same problem was still present...

    She then advised to take it back to the place I bought it from, for them to carry out further tests/swap the phone...

    I'm just hoping Allphones have more 3GS's...
     

Share This Page