3GS Error 29 when trying to load 4.3.4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by poundman, Jul 22, 2011.

  1. poundman macrumors newbie

    Joined:
    Jul 22, 2011
    #1
    Tried to update my 3GS phone with AT&T GO card with 4.3.4 from 4.3.3 Never had jailbreak before. Install failed and when into recovery mode but it will not complete with error code 29 which apple store says is hardware failure.

    I have replaced the battery and digitizer screen but it was working great before today. Is there anyway to re-install 4.3.3 image? Where can I get it? Is it on my PC? I tried fixed recovery and it appears it was succesful. But when I used itunes to recovery it still fails

    Help? What tools do I need now?
     
  2. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #2
    Put your iPhone in DFU mode and try to restore again.
     
  3. poundman, Jul 23, 2011
    Last edited: Jul 23, 2011

    poundman thread starter macrumors newbie

    Joined:
    Jul 22, 2011
    #3
    Still no luck

    Put in DFU mode but still no luck. Tried fix recovery tool, not luck.
    Is Iphone2,1 = 3GS? I wonder if the screen replacement has anything to do with this? Could it be that it thinks I have 3G phone isntead.

    I'm willing to try and firmware to get it running again
     
  4. poundman thread starter macrumors newbie

    Joined:
    Jul 22, 2011
    #4
    Ok, I think I have found the problem. Recovery log has this error

    entering update_gas_gauge
    0: RamrodErrorDomain/3ea: update_gas_gauge: gasgauge_swupdate returned -1
    attempting to dump restore log
    writing log file: /mnt1/restore.log

    Other searches indicate this is caused by after market battery I used. Any way to bypass this or where can I get a battery that will work.
     
  5. poundman thread starter macrumors newbie

    Joined:
    Jul 22, 2011
    #5
    New battery from directfix.com was the solution. By that time 4.3.5 installed just fine. Don't bother with ebay when getting a battery. Save some time and go directly to directfix.com for only $15
     

Share This Page