3gs hanging on the Apple logo.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by GazNicki, Dec 5, 2012.

  1. GazNicki macrumors newbie

    Joined:
    Dec 5, 2012
    #1
    I have a 3gs which has needed almost everything replacing. In total I have replaced the gps module, and reseated the metal bezel. I rebuilt and found it needed a new battery and a new bottom dock.

    I have since replaced the bottom dock and fitted a new battery, and when I have rebuilt it powers on to the Apple logo. It now holds charge too and is recognised by iTunes. However, it is hanging on the Apple logo and won't do anything. Holding the home and power buttons seems to do nothing either.

    If I restore in iTunes it will update to ios6, and I really don't know what to do. This is my first time with an iphone and my first time fixing one, so any help would be much appreciated.

    Sent from my X10i using Tapatalk 2
     
  2. Fredvs79 macrumors newbie

    Joined:
    Feb 24, 2012
    #2
    Is it hanging while plugged in, or while running off the battery?

    I've had problems with replacement batteries causing it to hang. I think because they can't supply the full amperage necessary during the boot up process.

    If your power/home buttons don't work you might need to replace one/both of them- or their associated ribbon cables.
     
  3. GazNicki thread starter macrumors newbie

    Joined:
    Dec 5, 2012
    #3
    Hangs on both.

    The power button is fine and home button just had a brand new dock.
     

Share This Page