3GS help needed! "device isn't eligible for the requested build"

iceybigred

macrumors newbie
Original poster
Oct 18, 2007
14
0
last night my 3gs decided to go for a swim in some beer - end result pretty much as expected, the phone went crazy and turned off. ok, so i let it dry and revisiting today. it turns on but the touch screen no longer works (need a digitizer replacement i'm assuming?) and tells me to connect to itunes. i connected and tried to restore but i keep getting this error message:

"the iphone could not be restored. the device isn't eligible for the requested build"

i think it's a firmware issue, i had 3.0 and its trying to update at 3.1. or something like that?

my phone is not jailbroken so i'm not sure what my solutions are here...does anyone have advice on how to fix?
 

chargit

macrumors 6502a
Jan 17, 2010
924
0
Evansville, In
nope not firmware.....hardware! your phone could not possibly be dry if this happened last night! if you know what you are doing your phone needs to be taken apart and dried then cleaned. you need to get rid of any beer residue. you need to quit trying to use it or charge it. this just causes further damage
 

Intell

macrumors P6
Jan 24, 2010
18,886
380
Inside
The problem is Apple is no longer signing 3.1 firmware. The only version you can restore to is 4.0.1
 

Intell

macrumors P6
Jan 24, 2010
18,886
380
Inside
so there's no solution?
There is no way to go back to 3.1 or 3.1.3 unless you have your SHSH blobs saved. If you don't know what those are then you don't have them saved. To get your iPhone working again you must update it to 4.0.1.
 

iceybigred

macrumors newbie
Original poster
Oct 18, 2007
14
0
There is no way to go back to 3.1 or 3.1.3 unless you have your SHSH blobs saved. If you don't know what those are then you don't have them saved. To get your iPhone working again you must update it to 4.0.1.
given the state my phone is in, how would i update the firmware if it must be restored first.
 

chargit

macrumors 6502a
Jan 17, 2010
924
0
Evansville, In
before you worry about what firmware is or is not available you need to fix your water damage issue. that is your only problem!!! dont worry about any builds at the moment cause there is no reason you can think of not to upgrade to 4.0.1
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.