3GS Iphone Stuck in 'Restore Mode'

Discussion in 'iPhone' started by flashtrain, Jan 3, 2011.

  1. flashtrain macrumors newbie

    Joined:
    Jan 3, 2011
    #1
    Quick Summary:
    Home button wasnt working properly.
    Restore wouldn't work on PC.
    Used 'Erase all Data and settings' in iphone settings - then phone would get stuck on startup.
    Soft reset by plugging it in and holding both buttons - got it to show itunes logo and USB.
    Tried to restore it on Mac, goes in a loop - does whole process but iphone is still in restore mode when it finishes.
    I'll post a more detailed description below.

    Questions:
    Has anybody had a similar problem?
    Does anyone have suggestions for what I can do?
    If I take it into an apple store, will there be any evidence of the jailbreak I had on it? It was the 'JailBreakMe' one for iOS 4.0.1. I think. I'm pretty new at this.

    I'd really appreciate any help and I'll be very grateful.
     
  2. flashtrain thread starter macrumors newbie

    Joined:
    Jan 3, 2011
    #2
    Detailed Problem:
    Been having problems with Home button for last few days (ie sometimes phone acts as if the button is being held down, sometimes as if its being tapped, sometimes it works fine).

    Tried to software restore today. Wouldn't work on my PC for some reason, kept telling me it couldn't contact the apple servers. I gave up after updating and reinstalling everything twice.

    Used the 'Erase all data' option on the iphone settings, and then it wouldn't turn on at all. I did the whole reset thing by holding down both buttons and it went into restore mode (with the usb into the itunes logo).

    Switched to my sisters Mac and it worked. Sort of. It goes through the restore process, but then goes right back to the start with itunes telling me I need to 'Restore this Iphone before it can be used with Itunes' or something.
     

Share This Page