3GS JB, battery issues

Discussion in 'Jailbreaks and iOS Hacks' started by sshams95, Dec 11, 2009.

  1. sshams95 macrumors member

    Joined:
    Jul 12, 2009
    #1
    Facts: Iphone 3GS, running Pwnage 3.1.4 on OS 3.1.2. No unlock. JB apps include: SBSettings, Springlocker, 3g Unrestrictor, Mem Tool, NoAccessory Splash, Lockinfo, Weathericon, Ifile, Safari Download Mgr, Attachment Saver, YourTube, iSmart Dialer, ToneFX, PKgBackup

    Phone acquired the day of release back in the summer.


    Here’s my dilemma:

    A few days ago, I noticed bad battery drain plus every time I plugged in a charger to my Iphone, i would have to wiggle the charger to get Iphone charging. In addition, the screen kept on getting me “This accessory is not made for this device, etc” message. This happened for the most basic wall chargers. So I decided to restore back 3.1.2 using Pwnage. I have not ever restored to Apple’s OS 3.1.2.

    After restore, I used PKGBAckup to restore Cydia apps and repositories. Worked without issue.

    Now, I don’t have any issue with plugging in charger and having it wiggle to get it charging…seems to work w/o a problem.
    But battery drain is horrible. This morning, 3 ½ hours of use and I have dropped over 50% already. This is not normal behavior and it has behaved this way for the last 3 days. Basic stats:

    Usage 1 hour, 39 minutes
    Standby 3 hours, 24 minutes
    2 minutes in calls
    Sent 811kb and received 11.8mb of data

    Here are my options:

    1. Restore to Apple 3.1.2 and see if problems persist. If problems go away, then re-JB using Blackra1n as I can’t recall if Pwnage will work if I go to stock firmware, which updates modem firmware.
    2. If problems continue, then I’m stuck going to Apple for warranty repair. My guess is they will just give me a new one. If I get new one, I run the risk of getting a newer 3gs which means a tethered jailbreak.
    3. If problems continue, spend my own dollars and have a 3rd party source replace battery, which enables me to keep my 3gs and un tethered jailbreaks.

    I post this out there to get your feedback and suggestions.

    MODS: Please feel free to move this to correct area.

    Thanks!!
     
  2. dread macrumors 6502a

    Joined:
    Jun 16, 2009
    #2
    sounds like a hardware issue, just restore it and use it without the jailbreak to confirm.
     
  3. ckong macrumors regular

    Joined:
    Nov 12, 2009
    #3
    My $0.02...

    A while ago on Apple's forums, people had bad battery drain issues everytime the OS was upgraded. One of the causes was due to push notification. If you have anything that does use push (like Exchange Email), delete the account and then re-create it back. I did this when I upgraded to the 3.0 platform just to avoid problems.
     

Share This Page