3Gs No Sound

Discussion in 'iPhone Tips, Help and Troubleshooting' started by standingquiet, Jun 6, 2010.

  1. standingquiet macrumors 6502

    standingquiet

    Joined:
    Feb 13, 2010
    Location:
    Birmingham, AL
    #1
    Hey Guys

    My iPhone 3Gs keeps playing up for no reason it will come up on the screen something long the lines of

    "Accessory Not Supported in Phone mode would you like to switch to Flight mode"

    So i choose no and then the phone has no sound only ringtone when someone calls. Anything else you cannot hear. When you adjust the volume it says headphones so somehow the phone thinks headphones are connected which they are not. If i connect headphones i can hear sounds through them.

    Usually if i reset the phone it would fix the problem for afew days now even resetting it does not fix the problem.

    It is really annoying as the phone is not even a year old.

    Any help would be great

    Cheers

    Matt
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You got any water damage by any chance?
    Check the moist sensors.
     
  3. standingquiet thread starter macrumors 6502

    standingquiet

    Joined:
    Feb 13, 2010
    Location:
    Birmingham, AL
    #3
    Phone never been near water. Can't see any pink on the sensors.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.

Share This Page