3GS not charging / recognized even after dock assembly and other replacements

Discussion in 'iPhone Tips, Help and Troubleshooting' started by luisadastwin, Dec 20, 2012.

  1. luisadastwin, Dec 20, 2012
    Last edited: Dec 20, 2012

    luisadastwin macrumors regular

    luisadastwin

    Joined:
    Oct 9, 2010
    Location:
    Antas - Porto - Portugal - Europe
    #1
    Hello all,

    I've replaced the dock assembly to a new one and I noticed that my 3GS is not charging since then...
    And when connecting to PC, I get the "USB Device not recognized" error!

    I've tried the following:
    • Replacement of battery (just to watch it dry out again)
    • Replacement to the original dock assembly
    • Replacement of USB Cable
    • Replacement of Wall Charger

    I've also noticed that the little gold pin of the main board broke off... But it has nothing to do with it right?

    I'm supposing it is a main board issue... But what can I do? Is there anything on the main board to fix?

    I'm without a phone now... I wanted to fix this really hard...

    Thank you in advance!


    Luis
     
  2. luisadastwin thread starter macrumors regular

    luisadastwin

    Joined:
    Oct 9, 2010
    Location:
    Antas - Porto - Portugal - Europe
    #2
    I've also noticed that if the phone's off and if I connect it to a wall charger, it wakes up but then it doesn't charge...

    So, it detects the electrical charge but then it doesn't charge at all and turns off again...


    Anyone please? :(
     

Share This Page