3GS on 3.1.3 firmware, HELPPP! need unlock

Discussion in 'Jailbreaks and iOS Hacks' started by edgar.amarotova, Oct 11, 2010.

  1. edgar.amarotova macrumors newbie

    Joined:
    Sep 30, 2010
    Location:
    Texas
    #1
    ive a 3Gs new bootrom, its jailbroken and unlocked

    can i update to 4.0 or 4.0.1 and then use limera1n to jailbreak and then unlock

    im a newbie at this plz help me out, i hear lots of people say NOW YOU CANT UPDATE TO 4.0 or 4.0.1
     
  2. az988 macrumors member

    Joined:
    Dec 26, 2009
    #2
    Long story short, you will have to wait until an updated pwnage tool is released or the latest 3gs baseband is unlocked because iTunes will only allow you to install the latest firmware (4.1), which also updates your baseband. There is no unlock for this updated baseband yet.

    EDIT: Back when 4.0 or 4.0.1 were the latest iOS versions, did you manage to use TinyUmbrella (http://thefirmwareumbrella.blogspot.com/) to store your SHSH blobs 4.0 or 4.0.1 blobs? If you had them you could restore to 4.0 or 4.0.1, but they're not available anymore. I assumed you didn't get them since you're still on v3.1.3
     
  3. edgar.amarotova thread starter macrumors newbie

    Joined:
    Sep 30, 2010
    Location:
    Texas
    #3
    well, first of all, thank you very much for your response

    ive a question, can i download an old version of itunes like 9.2 install it and then download the 4.0 or 4.0.1 from any other website http://www.redmondpie.com/download-ios-4.0.1-for-iphone-4-iphone-3gs-3g-firmware/

    and the "restore" it?
     
  4. crawsfire macrumors member

    Joined:
    Oct 1, 2010
    #4
    You can but you won't be able to unlock it because you have the new bootrom. You need the old one unless something has changed.
     
  5. Myzhi macrumors 6502a

    Myzhi

    Joined:
    Dec 15, 2009
    #5
    With 3GS and newer devices, Apple uses SHSH security check to limit you to installing only the firmware they want, currently only 4.1. If you had save old SHSH files when Apple was still sending them out, you can trick iTunes into allowing you to install an older firmware. Thus, the big question, do you have SHSH files saved? If NO, you can only install 4.1 which also install 5.14 baseband = no unlock. If YES, google for instructions using Tinyumbrella or editing your host file.
     

Share This Page