iPhone 3GS on 4.1 and jailbroken wants to update.

Discussion in 'Jailbreaks and iOS Hacks' started by Browserz, Dec 5, 2012.

  1. Browserz macrumors newbie

    Joined:
    Oct 25, 2012
    #1
    Hi, I've got an iPhone 3GS that is jailbroken and unlocked on 4.1 right now.
    The phone was locked to AT&T according to multiple IMEI checkers i found online, and I saw that you could get it unlocked, I then bought an unlock online and later checked that all of the IMEI checkers said my phone was unlocked.

    My problem now is: I want to update to IOS 6.0.1 but every time i try to unlock I get problem errors 2, 21, and 1602

    I've tried these methods:
    Leave the phone on, connect to itunes, and attempt to update - Error 2
    Check host file (nothing) turned off firewall tried again Error 2
    Put phone in recoverymode : Error 21
    Check everything again, and still nothing looks wrong
    Put phone in DFU mode and try again: Error 1602

    Any ideas?
     
  2. Browserz thread starter macrumors newbie

    Joined:
    Oct 25, 2012
    #2
    apparently i can't upgrade to ios 5 since they dont support it anymore.
     
  3. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #3
    You need to set your host file to apple again, # 1602 means it is still pointing to Cydia

    use TinyUmbrella to set your host to apple in Advanced tab.

    What unlock do you use? Software unlock, Gevey or IMEI?

    In Cydia on top of main page it should give what SHSH/Blbs/Hashes you have.
    If it says 5.01 or 5.1.1 you can restore to that and do an untethered JB.

    Do you have old or new bootrom?

    Always give as much info as possible
     
  4. Xenomorph macrumors 65816

    Xenomorph

    Joined:
    Aug 6, 2008
    Location:
    St. Louis
    #5
    Who is "they"? If you have your iOS 5.0.1 or 5.1.1 SHSH blob, you can install it.
     
  5. Browserz thread starter macrumors newbie

    Joined:
    Oct 25, 2012
    #6
    This is what my host file looks like right now, I believe I set it correctly.
    I went into cydia and it says:

    SHSH: IOS 4.1, 5.0.1, 5.1.1, 6.0.1

    Is there a guide on how to update to 5.1.1? Or 6.0.1?

    I was using a software unlock, but i have the IMEI unlocked now.
    I have the old bootrom i believe, i remember checking it a long time ago.
    The first few characters of my serial number is

    86125M10***
     

Share This Page