iPhone 3GS: random reboots

Discussion in 'iOS 6' started by juju4, Feb 9, 2014.

  1. juju4 macrumors newbie

    Joined:
    Jun 3, 2011
    #1
    Hello,

    I recently recovered a used iPhone 3GS, had it officially unlocked, fully restored, updated to 6.1.3/latest available on it.
    And since, I have several freeze with or not reboot. Application goes shadowed or black, eventually go on reboot on itself, either I asked it (power long), usually multiples reboot 2 to 5 times in a row and after seems to go off/battery drained mode. I need to plug it on power to get it back, usually at least one hour and after start again.
    Not sure if it is a real reboot as the multi-tasking bar seems to keep opened applications
    It happens anytime on springboard, apple applications, others

    The only way it seems to keep it stable is keeping it connected to power (very useful for a mobile phone).

    I tried the following by jailbreaking
    - disabling multitasking w Ztoggle: seems to be not working/still have multitasking bar
    http://forum.macbidouille.com/index.php?showtopic=365054
    https://discussions.apple.com/thread/2471090?start=2220&tstart=0
    - switching mobilewatch
    http://www.sopertek.co.uk/3gs/
    - No reduce motion, only ios7: http://support.apple.com/kb/HT5595
    - No background app refresh, ios7 only too
    - turn off location service
    => didn't help

    Don't want to pay for a battery change on a so old iphone but if I could avoid buying a new smartphone.

    I checked most notably the following threads on the forum.
    http://forums.macrumors.com/showthread.php?t=1643168
    http://forums.macrumors.com/showthread.php?t=1643050
    http://forums.macrumors.com/showthread.php?t=1656521

    Some crash log read from Xcode
    Code:
    Hardware Model:      iPhone2,1
    Process:         locationd [54]
    Path:            /usr/libexec/locationd
    Identifier:      locationd
    Version:         ??? (???)
    Code Type:       ARM (Native)
    Parent Process:  launchd [1]
    
    Date/Time:       2014-01-21 14:26:00.031 -0500
    OS Version:      iOS 6.1.3 (10B329)
    Report Version:  104
    
    Exception Type:  EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000001, 0x000000000000defe
    Crashed Thread:  16
    <<<
    Hardware Model:      iPhone2,1
    Date/Time:       2014-01-15 21:35:42.602 +0100
    OS Version:      iOS 6.1.3 (10B329)
    
    vbat=4025,t=3006,v=4022,ac=355,f=262,rc=0,fcc=159,dc=1200,s=16395,fv=279,rd=17,ci=296,mic=0009000000000000000000000000000000000000000000000000000000000000,82=030a018d0601eeff2bfc4b000802bc811c0ffa00000000000000000000000000,88=005500e600e600e800fd00bb00a900c800ec00e000d60100012d01ec03cd04c1,89=000000e600e600e800fd00bb00a900c800ec00e000d60100012d01ec03cd04c1,82'=030a018d0601eeff2bfc4b000802bc811c0ffa00000000000000000000000000,88'=005500e600e600e800fd00bb00a900c800ec00e000d60100012d01ec03cd04c1,89'=000000e600e600e800fd00bb00a900c800ec00e000d60100012d01ec03cd04c1,ac'=0,t*=3006,v*=3910,ac*=0,f*=256,rc*=438,fcc*=688,dc*=
    <<<
    Hardware Model:      iPhone2,1
    Process:         MobileCal [570]
    Path:            /Applications/MobileCal.app/MobileCal
    Identifier:      MobileCal
    Version:         ??? (???)
    Code Type:       ARM (Native)
    Parent Process:  launchd [1]
    
    Date/Time:       2014-01-29 11:27:46.976 -0500
    OS Version:      iOS 6.1.3 (10B329)
    Report Version:  104
    
    Exception Type:  EXC_CRASH (SIGABRT)
    
    Any ideas?

    Thanks a lot

    Julien
     
  2. E2EK1EL macrumors 6502

    Joined:
    Nov 19, 2012
    #2
    Have you tried running it stock for a while? It is a 5 yr old phone, replacing the batt may not be the problem and it could even be a faulty transistor and capacitor on the logic board.
     
  3. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #3
    restore as NEW don't use backups

    if it is still giving you trouble, take it to apple (not a third party) to get the battery replaced (I think is like $69), but you get a refurb instead of a new battery AFAIK for the 3GS ;) That way you can be assured you don't spend on a battery when it might be something else.
     

Share This Page