3GS running 4.0 -> 5.0 with unlock?

Discussion in 'Jailbreaks and iOS Hacks' started by filmfanatic24, Oct 26, 2011.

  1. filmfanatic24 macrumors 6502

    Joined:
    Sep 5, 2007
    #1
    How do I get from 4.0 with no Jailbreak or unlock to 5.0 with an unlock?

    I've found a guide to preserving the baseband and upgrading to 5.0 but I need to know if I have to Jailbreak it first. Should I go to 4.3.3 first?

    HALP :)


    BTW it is on baseband 05.13.04
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Jailbreak and install Ultrasn0w to unlock it.

    If you have blob for 4.3.3, then you can create customs firmware for it and update to that, otherwise you have to go to OS5.
     
  3. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #3
    I'm doing this for someone who will probably never update it. I worry that doing a tethered update to 5.0 will confuse him.

    Would I be better off just doing an untethered jailbreak of 4.3.5 using Pwnage Tool?
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    4.3.5 is also tethered jailbreak and you can't even restore to that because Apple stops signing that firmware. Check to see if his phone has a old bootrom, if it does, then it will have untethered jailbreak with os5.
     
  5. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #5
    ok I followed a guide to see my bootrom but I'm not seeing where it should be in the system profiler. Perhaps it's because I'm running on Lion?
     
  6. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #6
    Run Idetector and see if you can find it. Also, Redsn0w gives you the instruction how to look for old/new via serial #s.
     
  7. filmfanatic24, Oct 26, 2011
    Last edited: Oct 26, 2011

    filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #7
    Idetector is Windows only and I'm on a Mac.

    I used F0recast and got this:

    [​IMG]



    I also see conflicting reports. Some say if the Model number isn't MC it is the old one and some say if the 4th and 5th digits of the serial number are 40 or lower it is the old one. Mine is MB and 50 so that seems to conflict.
     
  8. mushtaqc, Oct 26, 2011
    Last edited: Oct 26, 2011

    mushtaqc macrumors newbie

    Joined:
    Oct 26, 2011
    #8
    3Gs upgrade to ios5

    I did my 3Gs upgrade by preserving baseband but I have issue of loosing service provider bar (connection) and on surfing on net its know issue, if you are OK with lossing connection then go ahead otherwise wait till new fix by dev team.
     
  9. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #9
    I guess I will just update from 4.0 to 4.3.3 and jailbreak and unlock from there.


    Like I said, it's not for me and this person won't know the difference between 4.3.3 and 5.0. I just want it to be untethered and unlocked.
     
  10. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #10
    check to see if you have blob for 4.3.3. If not, you can't go to that firmware because Apple stops signing it.
     
  11. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #11

    Where would I go to check that? I can't just download the original ISPW file and run it through Pwnage Tool?
     
  12. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #12
    You can open Cydia on your phone, look on top and see what you have up there. Other way is to run tiny umbrella and it will tell you.
     
  13. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #13
    Ok I just used TinyUmbrella to save my SHSH. So can I just use Pwnage Tool to create a custom ISPW for 4.0 and just use that?
     
  14. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #14
    What did Tiny umbrella tell you? look at the log tab.
     
  15. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #15

    It says Cydia doesn't have the SHSH for my phone.

    So what are my options at this point? Pretty much impossible to do an untethered Jailbreak?
     
  16. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #16
    Your option is to wait for untethered jailbreak on OS5 or you can go to 4.1 which doesn't make sense for you to do because you are at 4.0 already.
     
  17. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #17
  18. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #18
    Grrr. Ok made custom IPSW with redsn0w to preserve baseband. Got in DFU mode (redsn0w confirmed) but when I go to restore it in iTunes by holding Option and clicking restore it tells me the phone isn't eligible for the upgrade.

    I made sure to select the new custom ISPW. I am running iTunes 10.5. I'm sure I'm in DFU (screen is black). What am I missing?
     
  19. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #19
    Ok, I get why it won't let me install any of the 4.xxx software because I don't have the shsh blobs, but why won't it let me install 5.0? It won't even let me install the stock 5.0!
     
  20. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #20
    Do you have tiny umbrella install on your computer? if so, it might be the reason, open it, click on advance and uncheck the box it set you want to restore to Apple firmware, you uncheck that box.
     
  21. filmfanatic24 thread starter macrumors 6502

    Joined:
    Sep 5, 2007
    #21
    Unchecked everything there and deleted TinyUmbrella, still does the same thing.
     
  22. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #22
    Are you sure you are getting "the phone isn't eligible for the upgrade"? this error happen when you try to restore to a firmware that Apple is no longer sign. So, it does not make sense that you are getting this error if you try to restore to os5.

    So, if you put your phone in DFU mode, hit restore and Itunes should restore it to the latest firmware for your 3GS which is os5.
     

Share This Page