3GS seems to always be searching for service...

Discussion in 'iPhone' started by jsquared, Jul 17, 2009.

  1. jsquared macrumors 6502

    jsquared

    Joined:
    Jul 2, 2008
    Location:
    Nashvegas, TN
    #1
    Recently My 3GS seems to be searching for service a lot more or it'll have No Service for an extended period of time. Should I call apple/att? Is there any trick to help this out?
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Do you leave 3G turned on all the time? Or only when you are using it?
     
  3. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #3
    I've noticed the same with my 3GS; and this is happening much more often than with my v1 iPhone and my 3G. I've not found a fix, yet....:eek::eek::eek:

    UPDATE: It searches while I'm on WiFi more than anything else. Most notable, is the fact that the cell phone/data bars are 0-1 at the most and many times "No Service" switching in and out, and eventually "Searching..."
     
  4. jsquared thread starter macrumors 6502

    jsquared

    Joined:
    Jul 2, 2008
    Location:
    Nashvegas, TN
    #4
    I live in 3G area and when it is working correctly usually have almost full 3G bars. So I leave it on all the time. However my building at work must be built from something that deters a cell signal b/c hardly anyone gets good service. However being my 3rd iPhone (original, 3g and 3gs) the 3GS gets less signal more often than the other two phones. My buddy's 3G will sometimes get better service when we are standing next to each other.
     

Share This Page