3GS SMS Problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by raushy, Jan 1, 2011.

  1. raushy macrumors newbie

    Joined:
    Jan 1, 2011
    #1
    Hi Guys,
    I have an iphone 3gs recently upgraded to the latest version IOS 4.1
    everything was good till some days but after a month my iphone stopped sending and receiving SMS from any number,whenever i try to send a text message the loading bar goes to almost 90% then it stops tried various methods like resetting all settings/network settings and removed all tweaks which I installed from Cydia but problem is lies same,then I inserted other number Sim Card no solution,tried my Sim Card in other mobile SMS sending/receiving is working fine,gone through some earlier post of this forum and dialed **5005*7672*+(my service center number) but still no solution,
    Guys please help me out...................................
     
  2. raushy thread starter macrumors newbie

    Joined:
    Jan 1, 2011
  3. ssdeg7 macrumors 6502a

    ssdeg7

    Joined:
    Jul 15, 2010
    #3
    If your iPhone is jailbroken maybe that's the problem, you should try to upgrade to 4.2.1 if you can or would like to, if not then try to restore again to 4.1 and jailbreak again, sometimes this is software problem that can be fixed with a simple restore.

    My guess is that your jailbreak tweeks ruined the software and you need to restore for everything to go back in place.
     
  4. Al3x87 macrumors member

    Joined:
    Sep 13, 2010
  5. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #5
    Wirelessly posted (iPhone 3GS: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148a Safari/6533.18.5)

    Right, if your iPhone is jailbroken, I point to that as the culprit. Otherwise I'd blame the cell carrier (if the problem only occurred in the same place). Also the latest iOS isn't 4.1 but 4.2.1 and my 3GS which isn't JB, sends SMS just fine.

    Try restoring it and see how it goes.
     
  6. raushy thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #6
    Restoring seems to be the answer
    So I will go for it
    But again don,t know the process of restore.
    Please guide me the step by step process of restore
    or may be any video link will be appreciated.
     
  7. raushy thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #7
    Ok
    Done with restore with the help of a friend,
    restored 4.1 half problem solved started receiving messages
    but unable to send it,Now What....................:confused:
    Please Help.....................
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Are you using it on official carrier?
    You tried calling them so they can help you set it up correct or maybe check to make sure everything is right on their end also?
     
  9. raushy thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #9
    @Applejuiced

    Yes iam using it in official carrier treid with them everything is seems to be fine at their end,even I tried with other sim of same carrier no change...
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    It might be an issue with the Text service number that you have to enter manually on the phone like you mentioned above. I had to do the same with a few iphone's cause someone was using very old Cingular sims.
    They didnt tell you the combination numbers and special characters to enter in order to get the text messanging server setup correct?
     

Share This Page