3GS stuck at Apple logo. Possible to jailbreak at 3.1.3?

Discussion in 'Jailbreaks and iOS Hacks' started by mrat93, Mar 30, 2010.

  1. mrat93 macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #1
    My iPhone 3GS was stuck at the Apple logo today, leaving me no choice but to restore. I tried restoring back to 3.1.2, but iTunes gave me an error saying that the iPhone is not eligible for that requested build. Is it possible for me to upgrade to 3.1.3 then rejailbreak? Sn0wbreeze says it'll jailbreak 3GS at 3.1.3 with the old bootrom and non-MC. I got my 3GS around when it came out. Does upgrading bring me to a new bootrom?

    Any help would be greatly appreciated! Thanks!
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    If you restore to 3.1.3, you get a new, currently unlockable baseband (5.12.xx)

    With regard to Sn0wbreeze, here is one posters 7 hour "battle" with Sn0wbreeze.

    http://forums.macrumors.com/showpost.php?p=9525413&postcount=14

    Likely no one here will recommend Sn0wbreeze
     
  3. mrat93 thread starter macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #3
    :eek: That looks harsh. So what do you suggest I use? Or should I wait to see what the hackers may release this Saturday?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    If the phone is currently jailbroken, has old bootrom and you can get it into recovery mode... then use Pwnage Tool to make or get from Internet a custom restore 3.1.2 IPSW and use iTunes to browse for it.

    Mac = option + restore or PC = shift + restore to browse with iTunes

    Just don't choose 3.1.3 by mistake.
     
  5. mrat93 thread starter macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #5
    If I make a custom firmware, will iTunes still give me this message?
     

    Attached Files:

  6. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #6
    Not if you're currently jailbroken. JBken devices don't check for build eligibility
     
  7. mrat93 thread starter macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #7
    I am already jailbroken. I tried to restore but I got error 1600.
     
  8. mrat93 thread starter macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #8
    I gave up. So now I'm restoring to 3.1.3. iTunes is stuck at "Waiting for iPhone" now. Should I be concerned?

    EDIT: Never mind! Currently restoring. Thanks for the help before, guys.
     
  9. zipeee2 macrumors newbie

    Joined:
    Mar 31, 2010
    #9
    I was in a similar situation yesterday...my 3GS was broken at apple boot. It had 3.1.2 JB with blacknra1n 5.11.07 baseband. Since I didn't have my hashes saved on Cydia, I used pwnagetool to create custom 3.1.3 firmware that itunes would accept (by selecting restore by holding the option key in iTunes) in recovery mode.

    The pwnge custom firmware updated my 3.1.3, kept it Jailbroken, and reinstalled cydia, and preserved my 5.11.07 baseband. Itunes doesn't seem to care whether the firmware is stock or custom as long as it's 3.1.3
     
  10. luvu01 macrumors regular

    Joined:
    Mar 7, 2010
    #10
    you are restoring to 3.1.2 or 3.1.3?
     
  11. msim20 macrumors member

    Joined:
    Feb 4, 2008
    #11
    hi, i have the same situation. iphone 3gs jailbroken and unlocked using blackra1n. now i am stuck at the apple logo. i had 3.1 i think with baseband being 5.11.07.

    can you confirm that your phone still works alright after what you did?
    thank you!!
     
  12. mrat93 thread starter macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #12
    It works fine, but it is unjailbroken on 3.1.3. You will lose your unlock if you do this.
     
  13. msim20 macrumors member

    Joined:
    Feb 4, 2008
    #13
    i was wondering if i could restore using pwnage - what @zipeee2 has done.
    would really like to retain my unlock.

    have a dead phone right now. waiting to figure out what to do
    :confused:
     
  14. actionsauce macrumors newbie

    Joined:
    Jan 21, 2010
    #14
    I have a jb (blackra1n) 3gs 3.1.2 untethered.

    While running mywi today my service just cut off ('no service' where bars are). I then closed out of mywi and tried to respring (bosspref), which froze for about 5 minutes. So I held power and home for 10 sec now I cant get passed the apple logo.

    While trying to boot up, a very faint pinwheel joins the apple logo and slowly tries to finish its cycle before going black and re-entering apple logo.

    To make matters worse, the phone is near dead and now the only other logo that appears is the red battery with a plug and bolt, or just bolt if Im plugged in. Instead of the iphone charging, it remains on the red battery for a couple minutes, then goes to the apple logo. I left it alone "charging" for 1hr 30min and it still wanted to die minutes after being unplugged.

    I have tried the following multiple times:

    -Fiddled with the power and home buttons
    -Power and home for 10 sec
    -mute button 4 times (up,down,up,down) power and home 6-10sec
    -put phone into recovery mode (dfu?.. phone had black screen) power and home 10 sec, release power continue to hold home briefly while plugged in. iTunes (9.1) recognized phone as being in recovery
    -Tried to charge for about an hour in this state.. did not work

    Finally I downloaded pwnage 3.1.5 and it recognized my phone while it was in recovery mode, enough for me to build the custom firmware package. I tried to restore with the pwnage bundle but I received "1600 error" and could not proceed. Any help or advice would be greatly appreciated. I will research more about 1600 and hopefully find a solution, but if anyone has anything please help!
     
  15. actionsauce macrumors newbie

    Joined:
    Jan 21, 2010
    #15
    Add to my list of failed attempts:

    -downgraded iTunes to 9.0.3, tried to restore with pwnage bundle and still received the error 1600
     
  16. actionsauce macrumors newbie

    Joined:
    Jan 21, 2010
    #16
    More to the list of failures:

    -switched usb ports and cords (error 1600 is said to be an issue with usb connection)
    -restarted everything computer, re-downloaded 3.1.3 bundle, attempted again

    The above resulted in the error 1600 message

    Then I tried to install pwnage firmware bundle 3.1.2 from http://www.felixbruns.de/iPod/firmware/ Still using iTunes 9.0.3

    It started to work, but when verifying with apple the same message that mrat93 got came up;.. "This device isnt eligible for the requested build"


    any ideas?.. anyone?
     
  17. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #17
    You understand that without your SHSH on file for 3.1.2 you will not be able to restore to a stock 3.1.2

    If you haven't restored to stock 3.1.3 yet AND your 3Gs has the OLD bootrom you might be able to install a Pwned FW (3.1.2 or 3.1.3) using Pwnagetool
     
  18. actionsauce macrumors newbie

    Joined:
    Jan 21, 2010
    #18
    Got it working!!... but my dumbass restored from my second iphone with the same name and the newer baseband for 3.1.3 :(

    Im guessing the problem was with the bundle that pwnage gives with the 3.1.5 and 3.1.4 for the 3.1.3 custom firmware... I downloaded the 3.1.3 package from the felix bruns link I posted above and it worked like a charm!

    So my suggestion for anyone having the same problem with the same error message, download the custom firmware from felix bruns:

    http://www.felixbruns.de/iPod/firmware/

    and instal from itunes 9.0.3 with Ali G's downgrade tutorial:

    http://www.youtube.com/watch?v=ZA-w4iBs_ZI

    *you will probably have to torrent 9.0.3

    I hope this helps, I guess I'll play with 4.0 until the new iphone comes out in June!!
     

Share This Page