3GS stuck in DFU mode (black screen)

Discussion in 'Jailbreaks and iOS Hacks' started by akhater, Apr 11, 2011.

  1. akhater, Apr 11, 2011
    Last edited: Apr 11, 2011

    akhater macrumors newbie

    Joined:
    Apr 11, 2011
    #1
    Hi Guys I need help

    I was updating a 3Gs from 4.0 to 4.3 and it got stuck in DFU mode.

    the update process to 4.3 was completed successfully but the phone wouldn't turn on. Now I can' do anything with it at all

    1) RedSn0w stuck on "Waiting for reboot"
    2) iTunes restore gives error 1601 (it always find it in recovery mode)
    3) iRecovery gives me No iPod/iPhone found
    4) TinyUmbrella just tells me "DFU Device Connected"

    I don't care for it to be Jailbroken or not I just want it to boot.

    EDIT: I tried greenpois0n and it says jailbreak successful but the phone has only a white screen ....

    Any idea at all ?
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    Make sure you host file is pointing to Apple instead of Cydia or locally by Tinyumbrella.
     
  3. akhater thread starter macrumors newbie

    Joined:
    Apr 11, 2011
    #3
    It is!

    When I try to do a clean restore, in Tinyumbrealla it shows "DFU device disconnected" and it never connects again. On iTunes it just reads "Preparing iPhone for restore" then error 1601

    I tried from 3 computers
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    Just to be sure, what does your host file say?
     
  5. akhater thread starter macrumors newbie

    Joined:
    Apr 11, 2011
    #5
    127.0.0.1 gs.apple.com


    and I have TinyUmbrella running with the server started and I can see the response in the logs
    thanks for the help
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #6
    Believe, 127...is pointing locally and not to Apple. Delete the line, or in Tinyumbrella, under advanced options, uncheck "Set Hist file to Cydia on exit". Exit Tinumbrella, and then, try to restore.
     
  7. akhater thread starter macrumors newbie

    Joined:
    Apr 11, 2011
    #7
    Yes now it is/was pointing locally

    I also tried removing the entries from the host files with the same issue !


    when I try to restore to 4.3.1, in TinyUmbrelly it gives me DFU device disconnectoed and never connects back and fails with error 1601

    when I try to restore to 4.3 or 4.2.1 in TU it connects back but fails directy with error 1600 !!


    Now
    C:\Windows\system32>ping gs.apple.com

    Pinging gs.apple.com.akadns.net [17.151.36.30] with 32 bytes of data:
     
  8. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #8
    Not sure why you are even bothering running Tinyumbrella if you are just trying to restore to 4.3.1. As long the host file is pointing to Apple, just use iTunes and try to restore. If that doesn't work, try usual stuff, different USB cable, USB port and/or disable any security programs. Next option is to do the same on another computer. If it all fails, could be a hardware issue and you will need to make an appointment with a genius guy at Apple.
     
  9. akhater thread starter macrumors newbie

    Joined:
    Apr 11, 2011
    #9
    It just didn't work with iTunes alone ! I tired it always give me error 1601 even from another PC !

    is it a brick phone ?
     
  10. Chief JB offica macrumors newbie

    Joined:
    Apr 20, 2011
    #10
    3GS stuck in DFU mode (black screen/White Screen) Fixed!! the hard way

    So i got this 3Gs off ebay running 4.3.1, 05.16 baseband (non Jailbroken). I did the Tethered 4.3.2 jailbreak coz Apple had already released 4.3.2 by the time i got the phone. Jailbreak went fine and tethered boot just fine. The following day it went off and failed to reboot. It stayed on black screen DFU mode and when i tried Recboot or Fix Recovery on Tiny Umbrella i'd get a white screen. Trying to restore on itunes just gave an error 1600 after being on "preparing iphone for restoration" for minutes.

    Dude, i tried every tool on the web for almost three days straight and nothing worked. Im not new to jailbreaking by the way but I ended up crashing my windows 7 on my boot camp coz i downloaded every recommended tool and lost all my preferences on the Imac as i tried to run some stupid commands on Terminal.

    Finally i gave up and decided to do it the old fashion way, "Unplug this son of a b!tch" and so i took the battery out. I opened up the phone, unplugged the LCD and pulled out the motherboard (to separate it from the battery - i didn't peel off the battery from the back cover coz by now its already by itself). I gave it a few minutes then put everything back together without much hope.

    I powered it up and...nothing! I put it on DFU mode by holding power and home buttons and itunes picked detected it on recovery. Pushed restore on itunes and the apple icon popped up and started restoring!! I was like Holy shnikes! Its now updated and running on 4.3.2 stock firmware. I'll work on jailbreaking tomorrow coz thats enough milestone. I thought my phone got BRICKED!! I think it just got jammed with too much mediocre code as you try every tool out there. Watch videos on youtube on how to disassemble the iphone.
     
  11. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #11
    no, is not bricked. You probably have the iPad BB (6.15.x) installed?
     
  12. umeshgaire macrumors newbie

    Joined:
    Sep 2, 2010
    #12
    Solved Problem Stuck in DFU..

    Don't worry Friend : just follow this steps correctly 100% sure to solved, some time datacable. Read Here
     
  13. Contivity macrumors newbie

    Joined:
    Feb 20, 2008

Share This Page