3GS stuck with error 1015 (4.3.5)

Discussion in 'Jailbreaks and iOS Hacks' started by ian3008, Aug 21, 2011.

  1. ian3008 macrumors newbie

    Joined:
    May 7, 2011
    #1
    Hi MacRumors!

    I'm having an issue with my jailbroken iPhone:

    I was trying to restore (Unjailbreak) it, but iTunes gave me error 1015. I have tried tinyumbrella and Tinyumbrella (fix recovery) on Mac, but have had no luck.

    I also tried to downgrade to 4.3.4. and 4.3.3 to see if I could get it out of 1015. Naturally, I changed the Hosts file to allow this to work, but it still wouldn't boot.

    At the moment, I'm willing to try anything to get it to boot, jailbroken or not.

    If you need any more information from me, just say.

    Thanks!
     
  2. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #3
    If the above does not work, you can give Recboot a try. :)
     
  3. ian3008 thread starter macrumors newbie

    Joined:
    May 7, 2011
    #4
    What is the latest version?
     
  4. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #5
    Windows or Mac?

    Not the latest versions, but they should work. Don't worry about viruses, these files are from my Mediafire account, so I checked before uploading them to my account.
     
  5. ian3008 thread starter macrumors newbie

    Joined:
    May 7, 2011
    #6
    Used Recboot on 4.3.5. Nothing happened. Still in recovery mode. I guess this means I'll have to downgrade?

    Can someone help me with that?
     
  6. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #7
    This should help in downgrading.
     
  7. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #8
    do you have shsh blobs? if so Tinyumbrella run the tss server and point it to the firmware google flexburns for all the firmware and Iclarified has tutorials.
     
  8. Tech Elementz macrumors 6502

    Joined:
    Jul 7, 2011
    #9
    iOS 4.1 is still being signed. That's why I suggested he restore to that. However, I have not confirmed it to work without SHSH blobs. Can anyone confirm that?
     
  9. ian3008 thread starter macrumors newbie

    Joined:
    May 7, 2011
    #10
    I'm getting error 1600 on the downgrade. Any ideas?
     
  10. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #11
    You are correct 4.1 is being signed but for 3gS not IP4, and hence he does not need SHSH blobs.

    Op the 1600 error generally means you are not in pwned DFU correctly. However, if you want to restore to standard 4.1 from apple you should not need to be in pwned DFU.

    Can you describe exactly what you are doing when trying to restore.
     
  11. ian3008 thread starter macrumors newbie

    Joined:
    May 7, 2011
    #12
    I got it to install 4.1, but I can't get it to exit recovery mode, still.
     
  12. ian3008 thread starter macrumors newbie

    Joined:
    May 7, 2011
    #13
    Solution!

    I solved the issue and got myself into a working Jailbreak of 4.1.

    To do this on a Mac running 10.7 I used Redsn0w and Tinyumbrella as well as recboot.

    1. I downloaded the 4.1 IPSW file from here
    2. I started Tinyumbrella, went into the advanced tab and selected "set hosts to Cydia on Exit", and then I quit and restarted the app.
    3. In Tinyumbrella I clicked "Start TSS Server"
    4. I opened redsn0w and selected the 4.1 IPSW. I was only putting it in Pwnage DFU mode, so it don't matter yet.
    4. I opened iTunes and when invited to restore my iPhone, I held down 'alt' and clicked the restore button. Navigating to the 4.1 IPSW file, I installed it.
    5. Once that process was complete I opened redsn0w again and navigated to the IPSW file. I installed cydia and let the device reboot.
    6. The device still did not boot so I went back into redsn0w and clicked 'boot tethered'.

    I now have a working, though not ideal, iPhone.

    If anyone knows how to remove a Jailbreak, I would be most appreciative.

    Thanks.
     
  13. plshelpineedit macrumors newbie

    Joined:
    Aug 13, 2011
    #14
    this way you have a tethered boot, it sucks. Delete the host file, enter in pwned dfu with snowbreeze's ireb and create a custom 4.1 w/ snowbreeze.
     
  14. sud007 macrumors newbie

    Joined:
    Sep 29, 2011
    #15
    unable to get into tethered boot

    i have the same problem as 'ion3008' has...but i was successfully able to downgrade 4.3.5 to4.3.3 with redsnow, but not a tethered one. And as soon as it loaded there were no apps!
    just cydia!

    and just for the tym i left it on the bed for a minute, its light went off, and never booted just went into DFU, and even tryng to tethered boot, redsnow stucks on 'waiting for device to reboot'

    had to open it up and separate its hardboard from battery for 30mins to bring it back to , be able to get normal instructions as earlier!


    read here about 4.1 one nice idea, tried it, same way you told (to get a untethered one, but after all the procedures while it was to reboot, went in to DFU, tethered booted via redsnow, it booted , apps loaded, sudden shutdown...and again into same DFU loop..no boot no instructions
    finally I am to open it again, cant wait for days to let its battery and rom get empty.
    now please tell how to successfully get it on 4.1 or any firmware where it can run.

    same config: iphone3gs, bb- 6.15, TU shows 4.3.3 yet!

    ----------

    got any success??
    ihad same problem as u buds!
     
  15. Fantasigraphic macrumors 65816

    Joined:
    Mar 25, 2009
    Location:
    TN
    #16
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    To get FixRecovery to kick out of recovery (1013 error) you have to put iPhone back info DFU mode.
     

Share This Page