3GS Tethering Strange Issue - Preference Removed when connected via USB

Discussion in 'iPhone' started by merlin144, Jun 22, 2009.

  1. merlin144 macrumors newbie

    Joined:
    Jun 22, 2009
    #1
    Just got my 3GS in the mail today - sweet.

    I had already upgraded my 3G to 3.0, and enabled tethering, which works perfectly over Bluetooth and USB connected to my early 2008 Macbook (which doesn't need recent Bluetooth 2.0 update from Apple).

    Here's what's happening with the 3GS over Bluetooth:
    1. Pair over bluetooth, with tethering set to 'On'.
    2. Initiate connection from Macbook bluetooth menu > select 'Connect to Network'.
    3. Connection works for ~2 seconds then drops.
    4. I deleted Network Profile 'Bluetooth PAN', 'forgot' Macbook bluetooth connection from iPhone, 'forgot' iPhone bluetooth connection from Macbook, restarted both, rinsed, and repeated FIVE times. Same symptoms every time!

    ...so... let's try this over USB...

    1. Plug in iPhone.
    2. Popup for New Network Connection appears, confirm and hit 'Apply' in Network sysprefs tab.
    3. Nothing happens. Check iPhone for blue 'tethering status window', nothing is there. Check iTunes, shows iPhone as connected to computer.
    4. Check in Settings>General>Network AND TETHERING OPTION HAS DISAPPEARED.
    5. Reinstall Carrier Settings to enable tethering, restart iPhone and Macbook, and repeat. SAME THING HAPPENS.

    Help? Is there a killswitch being executed by iTunes that resets this until ATT approves tethering? Why is this only happening on 3GS?

    Thanks for your help. I searched and searched and haven't seen this problem yet.

    Edit: See post #10, some solutions are now available, but just workarounds.
     
  2. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
  3. merlin144 thread starter macrumors newbie

    Joined:
    Jun 22, 2009
  4. speakeasy macrumors newbie

    Joined:
    May 4, 2005
  5. carichard macrumors newbie

    Joined:
    Aug 5, 2008
    #5
    Partial Fix..

    I had the same problem. In my case it appears the Bluetooth wrecked the tethering. So, I reloaded the tethering and this time set it up to operate on the USB cable only. I'm operating on tethering just fine over the USB cable as I type this. Would like to have the convenience of the Bluetooth tethering, but I'll settle for at least a reliable USB tethering until this all gets sorted out.
     
  6. hanschien macrumors 6502

    hanschien

    Joined:
    Oct 2, 2006
    Location:
    Houston, TX
    #6
    Did you guys install the Bluetooth firmware update? I had the same problem with bluetooth disconnecting on my MBA.
     
  7. carichard macrumors newbie

    Joined:
    Aug 5, 2008
    #7
    Bluetooth Update...

    Yes, I had installed the Bluetooth update. I too have a MBA.
     
  8. speakeasy macrumors newbie

    Joined:
    May 4, 2005
    #8
    Actually, upon reading the posts again, I'm having a slightly different problem. After attempting to install the tethering pane (for USB only), my wifi died and now the wifi panel in settings is greyed out and just says no wi-fi. I immediately removed the new profile, tried a network reset and a full reset, all to no avail.

    Is anyone else having wifi problems after setting up tethering?
     
  9. merlin144 thread starter macrumors newbie

    Joined:
    Jun 22, 2009
    #9
    OK, I've solved the problem on my 3GS. At the advice of carichard, I've tried to set up USB tethering with no bluetooth tethering enabled. Here's the steps I took:

    1. Again did all the usual 'enable tethering stuff', then restarted phone.
    2. Plug 3GS in via USB. At first, I couldn't get the 'Network Adapter Detected' box to pop up.
    3. Restarted Macbook, still couldn't get the 'detected' box to pop up.
    4. Opened Network Prefs, and hit the 'plus' button to add a new network connection. Under 'Interface' selected "Ethernet Adapter (en8)".
    5. Hit the 'Apply' button.
    6. WOOHOOO! Got a green light, and tethering is now connected and stable.

    Ran a speed test, 2.5Mbps Down, .25Mbps Up!!
     
  10. merlin144 thread starter macrumors newbie

    Joined:
    Jun 22, 2009
    #10
    Problem solved?

    I decided to attempt a Bluetooth Tethering connection after the above worked - and this worked perfectly as well.

    BUT THEN I decided to see if my Visual Voicemail was still working. It didn't appear to be. So under General>Network>Cellular Data Network, I changed the setting under Visual Voicemail from wap.cingular to acds.voicemail.

    Visual voicemail started working without a restart, but the next time I connected via Bluetooth, tethering didn't start, and the Internet Tethering option had disappeared. I got tethering back, then tried via USB, which didn't work. Checked again, Internet Tethering has disappeared.

    I went to Cellular Data Network settings, hit the reset button, restarted phone, and Internet Tethering has magically reappeared! (Much quicker way to get it back!) BUT the visual voicemail settings have been changed back to wap.cingular. And with further testing, although Visual Voicemail still appears instead of dialing voicemail, I am not receiving messages. They're just sitting on the ATT server. :( :(

    Edit:
    After some further reading on the internet, I've found that the two may be mutually exclusive right now. So my workaround is this:
    For tethering, accept that VV will be disabled and messages will not be delivered. Use Cellular Data reset button + restart to get it going again, even while on the road.
    For normal iPhone use, set VV to acds.voicemail, accept that tethering will not be available without workaround.

    Thoughts? Better ideas?
     

Share This Page