3GS "This Device is not eligible for the requested build"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Iamjoshlee, Oct 12, 2011.

  1. Iamjoshlee, Oct 12, 2011
    Last edited: Dec 28, 2012
  2. Trevork97 macrumors newbie

    Joined:
    Oct 14, 2011
    #2
    How did you fix this problem?

    I am running 4.3.3 and I tried upgrade too ios 5.0 on my 3gs and came across the same issue .. if you can help me out I would appreciate it!
     
  3. seattlemac macrumors member

    seattlemac

    Joined:
    Aug 26, 2003
    #3
    Incompatible

    Yeah, after 45 minutes of downloading and more of installing - then it says, can't install because incompatible - huh???? I thought the 3Gs was okay.
    Any suggestions?
     
  4. ron808 macrumors regular

    ron808

    Joined:
    Oct 13, 2011
    Location:
    West Coast, USA
  5. seattlemac macrumors member

    seattlemac

    Joined:
    Aug 26, 2003
    #5
    yes - 10.5

    I have the 3Gs and iTunes 10.5 .... why not compatible?
     
  6. JunkyDog macrumors 6502

    Joined:
    Sep 17, 2011
    #6
    iPhone2,1_5.0_9A334_Restore.ipsw <- this is the correct software for iPhone 3GS, so are you sure you have the right one, why im telling this, i had the same problem until i discovered that i had the wrong ipsw file, so i downloaded this, and viola, worked fine.. :)

    And if you say you have the latest itunes, it should not be a problem at all..
     
  7. seattlemac macrumors member

    seattlemac

    Joined:
    Aug 26, 2003
    #7
    That was it - I downloaded, and then installed the update on the iPhone, and now it is in the process..... Thank you!
     
  8. pedrovegajr macrumors newbie

    Joined:
    Oct 16, 2011
  9. JunkyDog macrumors 6502

    Joined:
    Sep 17, 2011
    #9
    By downloading the correct ipsw for the 3GS iPhone, what else??

    Do you have the same problem:p
     
  10. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #10
    Restore on a different computer. I wanted to restore my new my new 4S because I was having syncing problems and was getting the same error. After a fresh restore my problems disappeared.
     

Share This Page