3GS - Why is my WiFi so slow?

Discussion in 'iPhone' started by scottuf, Jun 28, 2009.

  1. scottuf macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #1
    I've been playing with my 3GS for about a week now, and what I've noticed is that my WiFi speeds aren't really better in the download than 3g. This is kind of annoying. And it doesn't seem to just be at home, but anywhere I can get WiFi. For example, I just ran speedtest.net on my uMBP using my Airport Express (older B/G version, not N) and got 9.4 down - 1.87 up, and right before that on my 3GS I got a paltry 1.64 down and .44 up. This compares to a connection on 3g with WiFi off of 1.48 down and .07 up (yes I know the up sucks on 3g). So from a down loading standpoint 3g is on par with WiFi, at least on all of the tests i've run.

    I've used the "Check Pipes" app from CNet and get similar results. Is this just my phone or does it seem to be common among 3GS's? Yes I've seen other threads where people have complained, but also seen threads with high WiFi speeds.

    Some screenshots:
    [​IMG]

    [​IMG]
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Okay, that's the worst I've seen! Have you done a restore?
     
  3. scottuf thread starter macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #3
    not yet. and i made sure my uMBP wasn't using any bandwidth while i was running the test on the iphone. ugh!

    i'll try a restore next i guess.
     
  4. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #4
    Hmm, before restore, put your phone in Airplane mode then re-enable WiFi. Those numbers look like 3G numbers.

    I take a hit on mine too (due to encryption, etc). I have a 20Mbps down, 20Mbps up connection and I just got 15Mbps down and 10.5Mbps up from my 3GS.
     
  5. scottuf thread starter macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #5
    well airplane mode did no good. i guess my next step before a restore is to stop by the apple store and see if i can compare to some of the iphones there.

    [​IMG]
     
  6. YoungLew macrumors regular

    Joined:
    Jun 8, 2009
    #6
    mines the exact same

    the best speed i've managed to pull on WiFi is 3.97 on a 10MB link..

    but my average speed is more like the ones you've shown.....

    i thought it was just how the device was.....
     
  7. kas23 macrumors 603

    kas23

    Joined:
    Oct 28, 2007
    #7
    You guys should restore or take it back. The "S" is supposed to be for Speed not Slow.

    Also, try it on a different WiFi. Go to a Starbucks or BnN.
     
  8. pablo7 macrumors 6502

    Joined:
    Nov 10, 2008
    Location:
    LOS ANGELES, CA.
    #8
    Heres' my results they really suck alredy exchanged one 3gs for cracks now this..my other 3gs was just as slow so I might have to check another wifi set-up first....
     

    Attached Files:

  9. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #9
    Okay, I looked at your units wrong! You're in Mb/S. Actually, that's BLAZING fast (for the OP), so what are you complaining about?? I get 2.6 Mb/S down and around 0.7 up.

    Oops, still misread your post, those 1st numbers were not for your iPhone. So, I'm not sure what's up, but you probably should do a restore or go back to the store.
     
  10. scottuf thread starter macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #10
    the units on the phone match the macbook. the phone is definitely slower. i should think that on the same connection (wifi), i should get near same speeds.

    restore done, same results. made my genius appt for tues (soonest they had)
     
  11. Merlinwiz macrumors member

    Joined:
    Jul 4, 2008
    #11
    Same here, I consistently get downloads of 7mbps on my laptop but on my 3gs the best I have ever got is 1.68mbps normally around 1mbs :(
     
  12. RKilbane20 macrumors 6502a

    Joined:
    Jun 9, 2009
    #12
    I ran a speed test on my computer and got 30 megs a second which is fast but then my wifi on my phone barely gets 1.5. How can it drop so much?
     

Share This Page