3gs won't display ipod info/songs when plugged into car

Discussion in 'Jailbreaks and iOS Hacks' started by nissin, Dec 15, 2009.

  1. nissin macrumors newbie

    Joined:
    Mar 19, 2008
    #1
    until apple released 3.1, when i would plug my 3gs into my jetta (i'm that guy with all apple products and a vw) through a dealer installed head unit cable it would just show a white screen with a grey ipod logo or something, nothing else. I couldn't change playlists/songs/shuffle etc. without unplugging my phone, doing what i needed to, then plugging it back in- it has always been like this ever since i had a 2g. but when apple released 3.1, it was normal. i could plug it in, and my ipod menus and everything would show and were accessible like it should be. but then i jailbroke with pwnage tool at 3.1.2, and now it has reverted to the annoying ass blank screen.
    under both circumstances, the box came up telling me that "this device is not compatible with this accessory" or something and then it would ask if i wanted to enter airplane mode.
    does anyone have a clue as to why this happened? i've searched for any info on a setting through the phone, or if it could be a setting through my unit in my car.

    thanks for the help
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Sounds like 3.1.2 changed the firmware resulting in the blank screen. Perhaps a conflict between iPhone firmware and vehicle/radio/display firmware.
     
  3. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #3
    I don't think this is a conflict, it's a feature; the idea is to prevent your being distracted looking at your phone while driving.

    OP: I'm not sure you can re-enable the display, but you can get rid of the accessory warning using Popup Blocker from the Cydia store. It let's you control all kinds of those blue popup notification windows.
     

Share This Page