3gs won't update to 4.2???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dangles, Nov 23, 2010.

  1. dangles macrumors newbie

    Joined:
    Jul 19, 2010
    #1
    so my 3gs won't auto-update to 4.2, and when i try to do it manually within itunes, a window keeps popping up saying that my version of itunes is the current version. i'm not trying to update itunes, i'm trying to update my phone!

    i'm still on OS 10.4.11 and itunes 9.2.1 as a result (can't get itunes 10 until i upgrade to OS 10.5 :().

    when my phone is plugged in, itunes tells me i still have iOS 4.1 and a newer version is available. but like is said above, if i click "update" a window pops up saying my itunes version is up to date and doesn't need updated.

    [​IMG]
     
  2. johnoporritt macrumors member

    Joined:
    Nov 9, 2010
    #2
    Is your phone jailbroken
     
  3. billd macrumors newbie

    Joined:
    Nov 23, 2010
    #3
    3gs won't update to 4.2???

    I have exact same problem. Phone is not jailbroken, has updated fine previously. Also on OS 10.4.11 (PPC) and iTunes 9.2.1
     
  4. silentsim macrumors regular

    Joined:
    Jul 9, 2010
  5. Interstella5555, Nov 23, 2010
    Last edited: Nov 23, 2010

    Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #5
    Sorry guys, you're not going to be able to do it.

    System requierments -
    iTunes 10.x - Mac OS X version 10.5 or later
    iOS 4.2 update - iTunes 10.1 or later

    I find it bizarre beyond belief that Apple has chosen to do this "SL Only" thing for the new phones and iOSs (and even iTunes). I definitely had to jump through some hoops to get in running on my Rev A MBP with a broken superdrive when I picked my 4 up in July, but at the end of the day it's $29...and still annoying.

    And, technically, its correct; that's the highest version of iTunes your OS can run.
     
  6. mattg72 macrumors newbie

    Joined:
    Nov 24, 2010
    #6
    :mad: This is unconscionable! So I have to buy a new freaking computer, so I can install the latest version of iTunes, so I can update my phone??? My G5 power mac works perfectly! I have no reason whatsoever to replace it! It cost me a bloody fortune what I bought it but it still functions like the day I bought it. It does everything I need it to do.

    I like Apple products and everything but this sort of BS is infuriating. Its deliberate and devious... and Steve Jobs can go f__k himself. :mad:
     
  7. billd macrumors newbie

    Joined:
    Nov 23, 2010
    #7
    Update iPhone with another computer?

    Does anyone know if, I update my iPhone to iOS 4.2 on another computer, if it will still sync work and sync on my older G5 running iTunes 9.2.1 ?
     
  8. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #8
    I don't think so, I feel like you'll still need iTunes 10.x to have the computer recognize the phone. Also funny that I tried to tell people this back in mid-June and everyone ignored me.

    http://forums.macrumors.com/showthread.php?t=938420&highlight=
     
  9. SuperKat macrumors regular

    Joined:
    Dec 14, 2008
    Location:
    In A Galaxy Far, Far Away
    #9
    Bogus

    Thanks for the link to this thread from the other one I started. Seems that i have an older iTunes version so I can't upgrade either. Oh well. It's pretty annoying.
     
  10. Briandb1222, Dec 2, 2010
    Last edited: Dec 2, 2010

    Briandb1222 macrumors newbie

    Joined:
    Nov 29, 2010
    #10
    I feel the pain. I have a iBook G4 (I bought it used, so it was cheap...can't complain on that part). I run 10.4.11 on it and it's frustrating that in order for me to be able to sync my phone is to buy a new computer (I want to buy a new Mac anyhow, so...).

    Oh, and uh, could just downgrade. The only real change in iPhone 4.2.1 is the ability to use AirPrint and some other useless crap. I don't even use that. I have a separate app that I use to print wirelessly.

    My ultimate suggestion is to buy a cheap Windows computer to use it for your iPhone. It don't need to be even the newest thing...it just needs to run Windows XP and you are good. I have a Gateway and I use that thing for my phone. Works like a charm...most of the time.
     

Share This Page