3rd gen iPod Touch - Music app crashing on a white screen

Discussion in 'iPod touch' started by evilspoons, Feb 6, 2012.

  1. evilspoons macrumors member

    Sep 3, 2007
    Hello everyone,

    I've had a 64 GB iPod touch, 3rd generation for a long time now. Never jailbroken, runs iOS 5.0.1, has 8,764 songs. It has mostly worked great for me, but this is the first time it's stumped me.

    I can't open the Music app any more. If you tap it from the main screen, it shows the "opening app" animation and goes to a white screen with a blue bar at the top and a black bar at the bottom, neither of which have any items on them. 20 seconds later the app disappears and we're left back at the home screen.

    When it stopped working I was using a smart playlist based on last played date and rating (very slow due to song quantity) and pressed Genius on a song. The Genius button switched to the spinner and never actually generated a Genius list.

    I tried to sync the iPod - I had it plugged into my Mac all night. I didn't really watch what iTunes was doing while it was syncing (since I was sleeping), but there weren't any errors in the morning... it still doesn't work though.

    I've also tried turning it off and back on again, and then hard-resetting it (two-button salute).

    Any ideas? Everything else seems to work fine (games, Safari, etc.)

  2. ShionoyaTamaki macrumors 6502

    Oct 9, 2011
    I have the same exact problem but on my iphone 4S 5.0.1

    Did you ever find a solution or the cause of this?
  3. rdy0329 macrumors 6502

    Mar 20, 2012

    Try updating it. Unless you're jailbroken.
  4. ShionoyaTamaki macrumors 6502

    Oct 9, 2011
    Been reading the apple forums and people who updated to 5.1 didn't fix the issue. But, I did found a fix for it, or at least the cause.

    Appears it is due to something with the cover art of certain music files or podcast. I resync with my iTunes removing the offending audio file and I was able to get it working again.

Share This Page