3rd Party Email Apps and Not Clearing Notifications

Discussion in 'iOS 8' started by iammike1, Jun 14, 2015.

  1. iammike1 macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #1
    So I have tried Gmail, Outlook, and CloudMagic to replace the built in Mail app on my 6+ but here is a common problem between all of them I don't remember always being an issue with 3rd party mail apps.

    When a new mail comes in, I am alerted, no problems. Because I'm sitting at my computer I'll check the mail there. The notification on the lock screen never goes away on my 6+ though...even when I get additional notifications for new mail later. The list just grows and grows until I unlock my phone.

    Am I imagining things that it didn't used to work this way? Has it always been like this? I slipped away to Android for about a year but now I'm back and trying to figure out this problem. lol
     
  2. mpavilion macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #2
    Some do, and some don't... I think Outlook does(?)
     
  3. pacorob macrumors 65832

    pacorob

    Joined:
    Apr 8, 2010
    Location:
    the Netherlands
    #3
    You could try Dropbox: Mailbox or Google's Inbox.
    I'm not sure if it has the feature you want.
     
  4. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #4
    I've tried a bunch of mail programs and I have noticed this as well. It's annoying. I'd us the built-in Mail app but the lack of push GMail makes it a non-starter. The GMail and Outlook apps both have push email, but then they have the notification issue you mentioned. If you end up finding an app that works, let me know.

    Facebook and FB Messenger have the same notification issue as well.
     
  5. Trahearne macrumors 6502

    Joined:
    Oct 6, 2014
    #5
    For third-party apps, there is no possible way to cancel a particular push notification without user interaction. Notifications are automatically cleared only when the badge is set to zero. So try to unread everything in your inbox, and all the previous notifications would go away.
     
  6. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #6
    Well that sucks, here's hoping that is changed in iOS9. When I was on Android it did this.
     

Share This Page