4.0.1 has way too many bugs. What is going on?

bababoey14

macrumors regular
Original poster
Jun 23, 2010
187
0
First of all my mail constantly freezes....mostly when I try and delete stuff. I have to go under settings and turn my account off then back on to reset.

Yesterday the camera would open but not let me take pics...I had to reset the phone. List goes on. Apple get your act together and fix all this foolishness with 4.1. Thanks and God bless.
 

localboy28

macrumors 6502a
Jul 27, 2010
791
11
I really hope they fix the zoom when you hit return bug

It's really annoying when writing long messages on forums.
 

lavrishevo

macrumors 68000
Jan 9, 2007
1,845
189
NJ
I have the 4.....seems to have gotten worse this past week. The camera issue was not big deal...but the mail freezing every other day or so is a bit much
I know this is a generic answer, but have you tried a restore and setup as new. Im not having any of those issued on my 4.
 

DynaFXD

macrumors 6502a
Jun 15, 2010
798
366
East Coast
I would agree. I don't call them "bugs", but there sure are a lot of rough edges. I've never bothered to write them all down, the GPS is not as accurate, viewing pictures sometimes gets all wonky, the multi-tasking and APPs have come to complete agreement on how to handle suspended operations, and so on. Nothing debilitating, but I suspect the iOS team has a laundry list of things to polish up in addition to the well known (and to me almost completely inconsequential) problems.

-shrug- the life of an early adopter. Device is great, warts and all.
 

Irish Rose

macrumors 65816
May 29, 2010
1,068
1
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

101AirAssault said:
Which phone do you have? No issues with 4.0.1 on my 4.
There are no bugs with this OS on my iP4 either. Everything seems to be working great with it so far.
 

bobbba

macrumors regular
Jul 7, 2008
207
7
I've not had any problems like this. Maybe there's problems with your mail provider.
 

vbman213

macrumors 6502
Apr 13, 2010
353
0
Who is providing your email? It sounds like you might be experiencing some IMAP errors from what you described above. I'm using GMAIL and I have no issues with mine!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.