4.0 fear...will it work on my 3G S if I do it now?

Discussion in 'Jailbreaks and iOS Hacks' started by giulianoaugusto, Jun 21, 2010.

  1. giulianoaugusto macrumors member

    Joined:
    Jun 18, 2009
    #1
    hey guys!
    got some newbie questions for all of you...
    I read all forum over and over and still couldnt find a clear answer...

    I have a 3G S running on 3.1.2 JB and unlocked via blackra1n...
    Since the guys from dev-team said all basebands are unlockable, can i just upgrade to 4.0 through iTunes and then JB using sprit/blacra1n or do I have to use a cutom IPSW already jailbroken?

    One last question, will 4.0 firmware change my baseband ? mine is 05.11.07
    thanks you guys!
    Love the forum, you rock!!
     
  2. appleguy123 macrumors 603

    appleguy123

    Joined:
    Apr 1, 2009
    Location:
    15 minutes in the future
    #2
    I don't think that there is any released jailbreak or unlock for 4.0 yet. I may be wring as I'm not actively following it (sold my iPhone in anticipation of iPhone4).
     
  3. Melodic macrumors member

    Joined:
    Sep 5, 2008
    Location:
    NYC
    #3
    This was posted on musclenerd's twitter


    "Reminder: iPhone3GS & iPod3G owners (especially if you used Spirit for your first JB) should stay away from iOS4 for now:"

    You should just wait a little longer
     

Share This Page