4.0 SDK doesn't support 3.x devices?

Discussion in 'iOS Programming' started by Brien, Jun 23, 2010.

  1. Brien macrumors 68020

    Brien

    Joined:
    Aug 11, 2008
    #1
    Is anyone else noticing that you can no longer target anything beyond 3.2 (iPad) or 4.0 (iPhone/iPod)?

    I suppose it's not the end of the world, but I'd still like original iPhone and iPod touch users to be able to use our software, but it looks like even a .1 update is going to alienate them, now.

    Ouch?

    (Sorry if this was already discussed, search didn't seem to find anything.)
     
  2. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #2
    You can, if you understand the difference between the Base SDK and iPhone OS Deployment Target build settings.
     
  3. macster84 macrumors member

    macster84

    Joined:
    Feb 21, 2009
    #3
    And if you don't see those options for older build targets in Xcode, during the install, you might not have checked the boxes to include support for the earlier versions. Various 3.x updates had those options. May need to reinstall 4.0.
     
  4. Brien thread starter macrumors 68020

    Brien

    Joined:
    Aug 11, 2008

Share This Page