4.01 and 5.13.04 - should I update anything?

Discussion in 'Jailbreaks and iOS Hacks' started by mds, Apr 12, 2011.

  1. mds macrumors 6502

    Joined:
    Oct 6, 2006
    #1
    Hey guys,

    Finally found a phone in town that hadn't been updated. It has already be jailbroken and unlocked and has a bunch of stuff already on it. Should I upgrade the OS? I know I have to preserve the baseband (gotta figure out how to do that). Anything else I need to update or things I need to know when updating?

    Thanks!

    Mike
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You can create a custom 4.3.1 JB ipsw with pwnage tool to save the unlock and go to the latest firmware.
    Make sure you hurry and start saving its blobs with tinyumbrella cause Apple is said to release 4.3.2 soon that patches the untethered JB used right now.
     
  3. mds thread starter macrumors 6502

    Joined:
    Oct 6, 2006
    #3
    Thanks!

    I saved my SHSH with tiny umbrella...should I update to 4.2.1 instead of 4.3.1? Seems people are experiencing issues with the 4.3.1 JB...will I have to reunlock my phone after updating via Pwnage Tool?
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    Hey Mike,

    Couple questions though?

    1. Which phone do you have? 3G, 3GS or Iphone 4. It was not indicated on the original post.
    2. When did you start SHSH blobs save?
     
  5. mds thread starter macrumors 6502

    Joined:
    Oct 6, 2006
    #5
    Whoops, sorry. I have a 3GS. I just saved the SHSH today.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    You should be fine with a 3GS.
    Just create a custom 4.3.1 with pwnage and then install ultrasnow from cydia to unlock again.
     
  7. mds thread starter macrumors 6502

    Joined:
    Oct 6, 2006
    #7
    Thanks! Does Pwnage preserve my baseband by default? I don't see a blatantly obvious setting for this, but I want to make sure I don't do anything stupid! haha...thanks guys, you're patience is much appreciated!
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Yes, there's no option but it does it automaticly.
    It creates a custom ipsw that updates the firmware but doesnt touch the baseband version.
     
  9. mds thread starter macrumors 6502

    Joined:
    Oct 6, 2006
    #9
    Awesome. I'd used it before but just used simple mode so some of the advanced stuff didn't make sense to me. If I can plow ahead with simple mode I think I'm in good shape! Hahah...Thanks!
     
  10. bilals macrumors newbie

    Joined:
    Jan 9, 2010
    #10
    Sorry to jump on the thread but I'm in a similar situation - 4.0(.1?) and 5.13.04. I used Pwnagetool to preserve bb and then used jailbreakme for 4.0.

    I'm tempted by 4.3.1 but I'm wondering whether I should update the baseband as well - do bb updates actually fix any phone-related issues or are they purely to plug holes and stop people unlocking? I have signal problems now and then(especially when switching to 3G) and am wondering whether a bb update would sort them out. I'm not interested in unlocking as I have the right sim but it would add value if I was to sell the phone on down the line. Of course, I'd rather update if it cured my problems. To be honest, I have a feeling my issues are related to tethering hacks I tried last year, so maybe a clean restore and not going near any apps that fiddle with the phone side of things would be enough?

    I only use one Cydia app(Wififofum) but it's really useful for my job otherwise I probably wouldn't even jailbreak as I just get everything from the App Store.

    Thanks
     
  11. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #11
    Updating the bb doesn't do anything but kill the software unlock and lessen the re-sale value of your phone.
    Try a restore with a custom firmware. If you don't need an unlock, then don't install ultrasnow until you need it.
    I suggest 4.2.1. It doesn't have any of the weird signal bar, MMS or voicemail issues that plague those with artificially low bb.
     
  12. bilals macrumors newbie

    Joined:
    Jan 9, 2010
    #12
    Thanks.

    The reason I wanted to go 4.3.1 was to see what the new javascript engine was like.

    I suppose 4.2.1 would probably be good, too, and as you say, there are weird problems for people with lower bb(and some threads on here about a swiping lock screen problem)
     
  13. mds thread starter macrumors 6502

    Joined:
    Oct 6, 2006
    #13
    I updated to 4.3.1 and everything seems to be working okay, though my email push isn't working. I haven't made any calls (I need to pick up a US sim), but I did successfully text myself with my Vodafone sim, so it seems to be working.
     
  14. bilals macrumors newbie

    Joined:
    Jan 9, 2010
    #14
    So your bb is still 5.13.04?

    Did you do that ultrasn0w for people using 4.3.1 with an older bb? I think it fixes signal issues and stuff, but what you say about push is worrying as I rely on that(it's also the reason I didn't bother unlocking yet and trying these push fixes).

    Hope it sorts it for you.
     
  15. mds thread starter macrumors 6502

    Joined:
    Oct 6, 2006
    #15
    Yeah. I did this all yesterday. Got a phone that was 4.01 and 5.13.04 (I'm the OP) and upgraded to 4.3.1 then unlocked with ultrasn0w. Push isn't working for me. I started another thread but haven't had a response on this issue. Not sure if its 4.3.1 or ultrasn0w that broke it....maybe I'll remove Ultrasn0w and see what happens...
     

Share This Page