4.1 update broke Bluetooth connectivity with my car

Discussion in 'iPhone Tips, Help and Troubleshooting' started by natallica, Sep 10, 2010.

  1. natallica macrumors 6502

    Joined:
    Mar 7, 2005
    Location:
    Fairfax, VA
    #1
    Hey all -

    Since updating to 4.1, my iPhone 4 won't stay connected to the Bluetooth in my 2010 VW for more than a couple of minutes.

    I've tried doing a hard reset of my phone and re-pairing with the car several times and it doesn't solve the issue.

    Anyone else?

    Thanks...

    -- N
     
  2. CyberBob859 macrumors 6502

    CyberBob859

    Joined:
    Jun 13, 2007
    #2
    I don't have a VW, but I've been having issues with my iPhone 3G using iOS 3.x and now 4.x with the factory-equipped Bluetooth in my '07 Nissan Sentra. I was hoping that the rumored "bluetooth fixes" in iOS 4.1 would solve some bugs I've experienced, but that hasn't happened.

    Before the iPhone, I had a Motorola Q on the Sprint network, and Bluetooth worked perfectly in my car with that phone. I find it hard to believe that the iPhone cannot perform better than an obsolete Windows Mobile phone in this regard.
     
  3. natallica thread starter macrumors 6502

    Joined:
    Mar 7, 2005
    Location:
    Fairfax, VA
    #3
    Agreed. The Bluetooth implementation seems to be lacking. My iPhone 3G had issues that I hoped the 4 would have solved.

    -- N
     
  4. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
    #4
    iP4 - iOS4.1 - Toyota 2010 Prius - Works normal. Lately I listen to my iP4 exclusively through BT and it's working fine. I just wish Apple would have implemented a more complete version of AVRCP.
     
  5. mzanker macrumors member

    Joined:
    Jul 14, 2008
    Location:
    United Kingdom
    #5
    Yes - 4.02 on my 3GS was working fine with my VW Bluetooth car kit (brand new car). As soon as I updated to 4.1 it won't stay connected for more than a few minutes. Like you I've tried resetting settings, deleting profile from car and iPhone, etc. - nothing works.

    Hope Apple fixes this soon.
     
  6. Ivan P macrumors 68030

    Ivan P

    Joined:
    Jan 17, 2008
    Location:
    Home
    #6
    Similar problem here too - since 4.1 my partner's 3GS won't connect to their Ford's stereo system. Worked flawlessly on 4.0.2 and below.
     
  7. TheShinyMac macrumors 6502a

    TheShinyMac

    Joined:
    Apr 3, 2009
    #7
    I would bring it to the dealer and let their techs try and reset the bluetooth on your car
     
  8. rstark18 macrumors 6502a

    Joined:
    Sep 18, 2009
  9. barfman macrumors newbie

    Joined:
    Sep 23, 2010
    #9
    Same problem with my 2009 BMW 320D

    I thought upgrading my iphone software was the right thing to do. My BMW service manager has now informed me that the updates do not work with the BMW bluetooth. I have the Iphone 3Gs now with OS 4.1. I will have to work out how to downgrade the OS to 3.0 or thereabouts in order to get it working again..... might just wait and see how the new WP7 phones do... I am fed up with useless Iphone updates that take away the main reason I have a mobile phone.... to make calls in my car...
     
  10. Black&Tan macrumors 6502a

    Black&Tan

    Joined:
    Mar 4, 2004
    #10
    I had to buy a 3rd party head unit, the Pioneer DEH-P710BT. Love it!

    It worked with a 3G running 3.2 and now works with the new iphone 4 running 4.1. From what I've read, Pioneer's implementation of Bluetooth works well with the iPhone software.
     

Share This Page