4.2 Beta and Proximity Sensor

Discussion in 'iPhone' started by jw nyc, Sep 15, 2010.

  1. jw nyc macrumors 6502a

    Joined:
    Jan 31, 2008
    #1
    Is it fixed yet? Mine is MUCH worse after 4.1 so hoping they finally got around to fixing it.
     
  2. HXGuy macrumors 68000

    Joined:
    Mar 25, 2010
    #2
    Its the phone, get a replacement from Apple. My previous (Week 31) iPhone 4 had the problem even after upgrading to 4.1 I went and got a replacement and the new one (Week 33) has been flawless.
     
  3. jw nyc thread starter macrumors 6502a

    Joined:
    Jan 31, 2008
    #3
    But I didn't have the issue anywhere NEAR as bad with 4.0.2! How could it be a hardware problem when the software made it worse!? :confused:
     
  4. Adisah macrumors regular

    Joined:
    May 29, 2008
    #4
    Did you try a restore without restoring from a backup?

    a "Clean Install"?
     
  5. techluvr macrumors regular

    Joined:
    Mar 22, 2010
    Location:
    OK, USA
    #5
    You have my exact story. Had a wk 31 that still had issues, replaced, and wound up with a flawless 33.
     
  6. djon41 macrumors regular

    Joined:
    Jan 7, 2007
    #6
    Can you usually just walk in to the store for this, or is an appointment necessary? I'm having major issues.
     
  7. jw nyc thread starter macrumors 6502a

    Joined:
    Jan 31, 2008
    #7
    Yes I did a clean install twice. Phone is much worse now then it was on 4.0.2.
     
  8. Skydivincoastie macrumors member

    Joined:
    Oct 31, 2008
    #8
    im in Apple right now and they will not give me a new one...they are doing a software update...even though I am already on 4.1...complete ********
     
  9. jacollins macrumors 6502a

    Joined:
    Jun 19, 2010
    #9
    And since you've done this before and it didn't work, it shouldn't work now. Demonstrate that and demand a replacement.

    On the other hand, if it works...
     

Share This Page