4.3 & 4.3.1 messed up my iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by saintforlife, Apr 10, 2011.

  1. saintforlife macrumors 6502a

    Joined:
    Feb 25, 2011
    #1
    My phone worked like a champ before the 4.3 update. All my problems started with the 4.3 update which killed the battery life, Apps started freezing, the phone became laggy and slow overall.

    I had hoped the 4.3.1 update would solve the issues, but it only helped marginally. The battery life is better, but still don't think it is at the pre 4.3 level. The home button is very flaky, sometimes it wakes up the phone, other times it does not. And the phone itself is slow, everything is laggy and animations for the apps opening/closing, moving between home screens is still very 'unsmooth', reminds me of what the 4.X update did to my iPhone 3G.

    Is this enough reason for a genius to replace my phone? It is very frustrating.
     
  2. Apple 26.2 Contributor

    Apple 26.2

    Joined:
    Jan 1, 2011
    Location:
    What up, 212?!
    #2
    I don't think it is, but you might want to check how many apps you're running in the background... some of your problems sound like ones associated with memory.
     
  3. caliguy macrumors regular

    caliguy

    Joined:
    Jun 12, 2005
    #3
    Same problem here. Very slow, even after closing all background apps. Right now for instance, my iPod won't hardly open (takes about 15 seconds) and then won't play a song. I quit the iPod process, rebooted my phone, and same results.

    Also, my home button is extremely unresponsive. Very little luck double clicking for fast app switching. Lastly, yesterday it just froze. It wouldn't wake, stuck on a black screen. I had to do a hard reset (wake/home).
     
  4. Stealthipad macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #4
    Maybe hardware problems. You just do not see that many complaining and you WOULD see it here!:eek:
     
  5. PeterB16 macrumors newbie

    Joined:
    Apr 11, 2011
    Location:
    Knoxville, TN
    #5
    Those you having problems with 4.3, are you jailbroke? AT&T or Verizon?
     
  6. caliguy macrumors regular

    caliguy

    Joined:
    Jun 12, 2005
  7. WeegieMac Guest

    WeegieMac

    Joined:
    Jan 29, 2008
    Location:
    Glasgow, UK
    #7
    Two iPhone 4's.

    Both unjailbroken.

    Tried on both O2 and Vodafone.
     
  8. oplix macrumors 65816

    oplix

    Joined:
    Jun 29, 2008
    Location:
    New York, NY
    #8
    sounds like either your memory or storage chips might be going bad.
     
  9. Mollemand macrumors regular

    Joined:
    Aug 1, 2007
    #9
    Same problem on my - never jailbreaked - iPhone4.

    A colleague of mine had the same problem after 4.3 - power consumption off-the-chart.

    I can't even power my iPhone from my MBP USB, I have to use a wall socket with the adapter to charge it.

    Apple forked up!:mad:
     
  10. WeegieMac Guest

    WeegieMac

    Joined:
    Jan 29, 2008
    Location:
    Glasgow, UK
    #10
    Seriously, don't talk rubbish.

    Go on the official boards, there's numerous threads there.

    I've replaced this phone, same issues.

    Don't jump to misguided, uninformed opinions.
     
  11. Mollemand macrumors regular

    Joined:
    Aug 1, 2007
    #11
    +1
     
  12. Mollemand, Apr 12, 2011
    Last edited: Apr 12, 2011

    Mollemand macrumors regular

    Joined:
    Aug 1, 2007
    #12
    Did I mention, my iPhone gets so warm it is uncomfortable to touch when it gets below 30% battery - no apps installed. (I removed all apps when I got the problem)

    When I charge it, it gets to more than 65 degrees celsius. [Edit] and it charges extremely slow.
     
  13. gregnauman macrumors regular

    Joined:
    Jun 25, 2010
    #13
    Mine is doing the same thing. Never since I switched to apple have I had as buggy an iPhone as I have now.

    Its like back to the palm or windows mobile days.

    I hope 4.3.2 fixes some of this, Installing right now.
     
  14. lympero macrumors 6502a

    lympero

    Joined:
    Sep 1, 2008
    Location:
    Arta, Greece
    #14
    Same problems here. Iphone 4 is laggy as hell! Set up as new didnt help either. I think 4.3.2 is little better but still my wife's iPhone 3GS with 4.2.1 is smoother! Thats ridiculous!
     

Share This Page