48gb of Other

Discussion in 'MacBook Air' started by wrinkster22, Jan 3, 2012.

  1. wrinkster22 macrumors 68030

    wrinkster22

    Joined:
    Jun 11, 2011
    Location:
    Toronto
    #1
    Hey Everybody,
    Recently I transferred all my files onto my new external Hard drive and did a Time Machine backup to my Harddrive. I thought that I would have freed a lot of storage but I have 50gb of other (well 48gb) Could anyone tell me how I could get rid of some of that? (Apologies if this has been answered and yes simsaladimbamba I tried advanced search :p )
    Screen Shot 2012-01-03 at 12.16.25 PM.png
    Thanks
     
  2. ashman70 macrumors 6502a

    Joined:
    Dec 20, 2010
    #2
    You need to determine what the 48GB of 'other' is, if the files don't fall under any of the other categories, they should be easy to locate.
     
  3. LAS.mac macrumors 6502

    Joined:
    May 6, 2009
    Location:
    Mexico
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Download Space Gremlin (http://www.spacegremlinapp.com/).
    That's a useful program able to tell you exactly what are the different portions of your HD used for.
     
  4. wrinkster22 thread starter macrumors 68030

    wrinkster22

    Joined:
    Jun 11, 2011
    Location:
    Toronto
    #4
    How do I determine this?
    EDIT: Could these be Time Machine Backups?
    The Space Gremlin app confuses me
     
  5. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #5
    By using finder or the terminal application. I can't post more right now since I am not at a computer but in my visitor messages there is a link on making finder useful. The command line du will be your friend in terminal
     
  6. mstrze macrumors 68000

    Joined:
    Nov 6, 2009
    #6
    No...see above. There is a color for 'Backups'
     
  7. jmgregory1 macrumors 65816

    jmgregory1

    Joined:
    Jun 24, 2010
    Location:
    Chicago and a few other places around the world
    #7
    It's Time Machine related - and will continue until you turn off local snapshots. You can do this through terminal using the sudo tmutil disablelocal command. It's really just a snapshot of your drive since your last backup.
     
  8. Stewart21 macrumors regular

    Joined:
    Dec 9, 2011
    Location:
    South Yorkshire
    #8
    I've just been playing with my MBA. I had 12.4GB of other. Fired up iPhoto and emptied the iPhoto trash. Other went down by almost 1GB. Give it a try, do it for all users you have on your machine.

    Do you empty your Downloads folder?, just doing a clear doesn't get rid of downloaded files.

    It should not be Time Machine backups as you say you've done a backup recently but turn it off and see if it makes a difference. I doubt it.

    I'm not a fan of so called cleaning utilities but if you are not familiar with the command line then download something like Diskdiet which is free and try getting rid of extra language files, caches, temporary files, and it can clear your downloads too. I just ran it on my iMac and it "claimed" I could free up 1.1GB even though my trash and download folders are empty.

    Stewart
     
  9. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #9
    This...

    Happens on all Lion portables when you aren't connected to the Time Machine Backup drive (i.e. when out and about). Run the command above and it will stop this "feature" and give you back the missing space. I had it consuming 40GB on my MBA before I realized.
     
  10. theSeb, Jan 3, 2012
    Last edited: Jan 3, 2012

    theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #10
    This isn't completely true. You'll have "Other" even if time machine is completely disabled.

    Other is everything else that does not fit into the categories that are shown in the graphics.

    So, it can be stuff like your word files, your powerpoint files, the OSX system files and so forth. In some cases the local snapshots can form part of this. All that graphic does is it tries to categorize files based on the spotlight index, your hard disk contents and the operating system's understanding of what files fall into what category. So photos will be files that are png, jpeg, gif and so forth.

    This is the drive on my MBA and my time machine is disabled. Just to double check I also disabled the local backups separately.

    [​IMG]

    Open up your Terminal (Applications --> Utilities) or type Terminal into the spotlight window in the top right (or cmd + space if you don't feel like clicking all the way over there on the search icon)

    Type in the commands as shown in the screenshot below

    [​IMG]

    This is the contents of your home folder, including the hidden directories. You'll see that I have quite a lot of stuff in the Music folder but I have no music on this computer. Yet the graphic shows that I have 789 MB of Audio.

    Why is that? It's because somewhere on my hard drive I do have audio files and the program that displays the graphic found them. They are not music files. They are audio files from applications and the system audio files that make the beeps and gongs when I do things like empty the trash. The Music folder is where your iTunes media folder is by default. I have a couple of movies and series in there, hence why it's that size.

    You'll note that there is another big folder called Library. This is where various things get stored that pertain to the user logged in. For example, if you use iMail, this is where your mail is. It's also where your application settings are and many other things that are beyond the scope of this discussion (because I am lazy tonight :D )

    Now follow the steps in the next screenshot.

    [​IMG]

    This is the root of your volume and you see folders like System, Private and Library. I am simplifying a lot, but you can think of those folders as where your operating system is. The Library folder has a similar job to the Library folder in your user folder discussed above, except this is now more generic stuff for ALL users, not just for you. There are things like system fonts in there and even sounds for Garageband. All of this stuff takes space. To follow this example back onto the topic: system fonts will be in the "Other" category.

    So what's that big Users folder? That's where all of the home directories for the users on this computer are. That's where my home directory is, which has MY movies, documents and so forth are.


    You can check it out if you want

    [​IMG]

    type in
    Code:
    cd Users/<username>
    
    or
    Code:
    cd Users
    cd <username>
    
    cd = change directory
    cd .. goes back a level - if I am at Users/sebastianp then cd .. will take me back to Users/

    ls - lists the contents of the directory. This is basically what you see in Finder, except that I've added the a and l flags which allow me to see the hidden files and folders and also shows the info in particular format. Try ls without the flags.

    Don't be afraid of your computer people. It's how you will learn. Take a back up and don't be afraid to see what makes it tick and tock.

    You can also explore your computer's hidden directories and files in Finder by typing this in the command line:

    Code:
    defaults write com.apple.finder AppleShowAllFiles TRUE
    killall Finder
    
    to disable it again

    Code:
    defaults write com.apple.finder AppleShowAllFiles FALSE
    killall Finder
    
    Now, if you set up Finder as per this post, then you can explore your hard drive quite easily
    http://forums.macrumors.com/showthread.php?t=1300195

    And one last tip for Finder. If you want to see the total size that a bunch of files and directories take up then highlight then or multi select them using cmd and then push cmd + alt + I and you will have one info screen for everything you have selected. Depending on how many files/directories you have selected, it may immediately calculate the total size or you may need to click "Calculate"
     
  11. yongren macrumors regular

    Joined:
    Jan 19, 2011
    #11
    Disk Inventory X is a good freeware program to find out where your storage space is going. I use it very often.
     
  12. Rolfmaomachizli macrumors member

    #12
    Download Daisydisk!

    Daisydisk is a free download, or i'm sure there is a trial, and it will lead you straight to the source with nice pie charts!
     
  13. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #13
    I was just about to post the same issue - but mine is even worse

    [​IMG]

    Ive tried daisy disk and some other disk utils and even scanning as admin can't reveal what files are taking up all this space.

    I have been working with some HD video files recently, without TM connected. I've done a TM backup since, several times but Lion hasn't copied the data over to my ext. HDD and deleted the local copies, so frustrating... assuming it is that.
     
  14. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #14
    If you follow the instructions above and use Terminal, it will be pretty easy to figure out where your space is.
     
  15. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #15
    I did try the terminal commands before however i didn't do them as sudo

    i've tried that and it' highlighted 40gb or thereabouts in the /Volumes/* folder... mobile back ups.

    However that doesn't tally up to the incredible 90gb that seems to have gone missing. And i'm disappointed Lion isn't clever enough to sync to time machine once plugged in, move the archive data over and clear it off the mac's HDD.

    I'm still at a loss as to how to clear this.

    11M ./.DocumentRevisions-V100
    2.0M ./.fseventsd
    4.0K ./.MobileBackups
    153M ./.Spotlight-V100
    0B ./.Trashes
    0B ./.vol
    4.2G ./Applications
    3.7M ./bin
    0B ./cores
    4.5K ./dev
    1.0K ./home
    4.0G ./Library
    1.0K ./net
    0B ./Network
    4.9G ./private
    2.3M ./sbin
    2.5G ./System
    21G ./Users
    428M ./usr
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/.Trashes: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/sbin: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/cores: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/Users: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/Applications: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/Volumes: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/.vol: No such file or directory
    du: ./Volumes/MobileBackups/Backups.backupdb/bp-mba/2012-01-04-122359/Macintosh HD/usr: No such file or directory
    14G ./Volumes
    51G .

    Sorry i got that wrong, volumes only stores 14GB...

    I have a tonne of No such file or directory... more than what i pasted
     
  16. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #16
    Ah. I've think seen this before. Can you tell me the rest of this line though? What was next to the 51G?

    You should not have anything in /Volumes apart from symbolic links and I recall another user had a similar issues on this forum a couple of months ago.

    Just to confirm. can you tell me what you get when you try
    ls -al /Volumes/

    ----------

    Here we go... I think this is what's happened

    from http://tech.kateva.org/2011/06/omnidisksweeper-finds-247gb-in-my-os-x.html

     
  17. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #17
    The 51G was the last item in the list and literally just like this

    Code:
     51G	.
    
    And the result of the command you asked for is:

    Code:
    total 28
    drwxrwxrwt@  7 root  admin   238  4 Jan 14:09 .
    drwxr-xr-x  32 root  wheel  1156  4 Jan 14:08 ..
    -rw-r--r--@  1 Ben   admin  6148 23 Dec 19:18 .DS_Store
    lrwxr-xr-x   1 root  admin     1  4 Jan 11:17 Macintosh HD -> /
    drwxrwxrwx   0 root  wheel     0  4 Jan 14:09 MobileBackups 1
    dr-xr-xr-x   4 Ben   staff   136 31 Jan  2009 WIB6_DISC_2
    drwxrwxr-x  17 Ben   staff   646  2 Jan 00:06 iBook 1TB
    
    And just to update

    I have since gone through TM and manually deleted all copies of the video files i've been playing with, 100's of gigs of them.

    They have now gone from TM and future files are ring fenced in a folder TM will exclude. Disappointingly this didn't solve the space issue. I even resorted to turning off local backups but that hasn't cleared the problem either.
     
  18. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #18
    I added more to my post at the same time as you posted.

    As I suspected, you have a duplicate of your Mobile Backups in /Volumes which shouldn't be there. There is nothing you can do within time machine or your backups to correct.

    You can, however, feel free to delete this.

    Code:
    cd /Volumes
    rm -rf MobileBackups\ 1 (you can type just Mobile and hit tab - it will autocomplete)
    
    If it gives you grief, then put a sudo in front. This isn't the first time I've seen this and other people have experienced the same problem. I cannot explain it, but I can only assume that it is an intermittent bug that occurs in certain circumstances.
     
  19. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #19
    Thanks I'm running this command and it's going through each file

    However it's saying Read Only File System at the end of each file in terminal.

    i'm not sure if it's deleting them... this is running it under sudo too


    //also
    finder reports mobile backups are only using 25.8GB

    hjmmm
     
  20. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #20
    Any update?

    What do you mean? Where do you see that exactly?

    What does df -h tell you?
     
  21. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #21
    Result!

    Thanks for your help

    As a last resort after rebooting i opened up disk utility and ran verify disk

    It came up with invalid block count!

    [​IMG]

    So i rebooted into recovery console and repaired the disk

    I now have my 90GB of free space back

    [​IMG]

    And the result of df -h

    Code:
    Filesystem      Size   Used  Avail Capacity  Mounted on
    /dev/disk0s2   112Gi   28Gi   84Gi    26%    /
    devfs          181Ki  181Ki    0Bi   100%    /dev
    map -hosts       0Bi    0Bi    0Bi   100%    /net
    map auto_home    0Bi    0Bi    0Bi   100%    /home
    
    And the output from rm -rf .... it basically did something like this

    /Volumes/Mobile Backup 1/bpa-mba/somenumber/system/library/fonts/somefont Read only file system

    I would run it again but i've disabled local backups and after disk repair mobile backs has gone from the /Volumes/ folder.

    ----------

    The question is

    Should i be worried that the SSD has become corrupt and had an invalid block count?
     
  22. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #22
    According to this http://support.apple.com/kb/TS2028 it is very much an issue at the software level (your file system itself) rather than a physical problem with your disk drive. Basically there is a bug in the HFS that occurs in some circumstances.

    I would monitor the situation and run disk utility every couple of days to make sure that the problem does not manifest again. Here is someone else that had the same issue:

    http://forums.macrumors.com/showthread.php?t=1262080
     
  23. Smileyboy macrumors 65816

    Smileyboy

    Joined:
    Aug 6, 2008
    #23
    I'd like a little help with this too

    I ran the info sighted in terminal and this is what I got:

    0B ./.config
    4.0K ./.cups
    25M ./.dropbox
    400K ./.Graboid
    0B ./.local
    112K ./.ssh
    0B ./.TemporaryItems
    0B ./.Trash
    0B ./.Xcode
    344K ./Applications (Parallels)
    8.0K ./Converted Files
    20M ./Desktop
    77M ./Documents
    308K ./Downloads
    4.4G ./Dropbox
    8.0K ./Graboid
    75G ./iPhoto Library
    45G ./Library
    2.2M ./Movies
    56G ./Music
    120K ./Pictures
    16K ./Public
    28K ./Sites
    536K ./business cards.bcard
    180G .



    Is this normal?
    Thanks
     

    Attached Files:

  24. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #24
    Have you tried running the disk checking utilities - it could be lion incorrectly reporting disk space like it was for me
     
  25. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #25
    i've been using disk inventory X for awhile now. It's easy to use, free and a great way to see what exactly is filling your HD/SSD

    http://www.derlien.com/
     

Share This Page