4G doesn't activate anymore

Discussion in 'iPhone Tips, Help and Troubleshooting' started by minato21, Nov 15, 2015.

  1. minato21 macrumors regular

    Joined:
    Aug 16, 2015
    #1
    I've had my 5s for a few months now and only once has 4G ever worked. Every time I try to use it my signal drops and it just displays "no service". If I reset network settings the option for 4G is on but its only using 3G and when I'm using the internet it will randomly lose signal then gain it again. Anyone ever have to deal with this before? Model is a iPhone 5s MF356X/A (back of the phone says A1530)
     
  2. bandofbrothers macrumors 601

    bandofbrothers

    Joined:
    Oct 14, 2007
    Location:
    Uk
    #2
    The sim may be failing which you could get replaced. Try another phone with 4G capabilities to test the sim card.

    Try another 4G SIM card in your phone if practicable.

    A Genius Bar would be able to check your iPhone over via an appointment.
     
  3. minato21 thread starter macrumors regular

    Joined:
    Aug 16, 2015
    #3
    My old SIM card was on my old Samsung s5 and 4g worked for that. But it doesn't work for my iPhone oddly enough. Could try a new sim. Sadly can't go to a Genius Bar since I don't know of any in New Zealand
     

Share This Page