4G iPod turns off on Apple logo

Discussion in 'iPod' started by brortao, Nov 25, 2009.

  1. brortao macrumors newbie

    Sep 2, 2009
    So my friend has a fourth-generation iPod (monochrome display, click wheel, physical hard drive). When you plug it into a computer (Mac or PC), it shows the battery icon but doesn't show up on the computer or in iTunes.

    When you try to turn it on, it displays the Apple logo for about 2 seconds before shutting down instantly. You can hear the hard drive making a high-pitched noise while it displays the logo, and it clicks when it turns off again.

    I tried leaving it in to charge for a while, and once it had enough juice to start up it displayed the Apple logo, turned off, and started again - it kept doing this until I plugged it out.
    I've tried resetting it, but that didn't work. Since it doesn't show up in iTunes, I can't restore it. Does anyone know of a way to fix this? There isn't a warranty on it, and no official Apple stores in my country. I hope there is some way to repair it. Thanks!

Share This Page