4G Touch on/off and volume buttons not working

Discussion in 'iPod touch' started by sunrisemusic, Jan 6, 2013.

  1. sunrisemusic macrumors member

    Dec 18, 2010
    This has only been in the last week or so - my 4G iTouch on/off and volume buttons seem to have stopped working. At first it was intermittent (I think they worked again after being connected to the computer)... I'm not sure if it's related but it seems to happen after I've had it hooked up to an iTouch FM connector in the car (powered by the cigarette lighter).... I'm about to hit the hay (not US timezone) so will see if how it is tomorrow. Connecting it to my Mac hasn't resolved it tonite (so far!)...

    Does anyone have any experience with this and/or ideas, suggestions? I'm guessing that if it's broken the cost to fix it might mean it's time to get an iTouch 5 :D though actually right now, I'd rather save my pennies...

    PS, it's using iOS 4.3.3 (I've been reticent to upgrade due to bad battery life and too many reports of iOS 5 and even 6 making - or possibly making - it worse, so I didn't want to risk it).


    Edit to add: PS - the Home button works fine.
  2. sunrisemusic thread starter macrumors member

    Dec 18, 2010
    PPS - I've tried holding down the power and home buttons for more than a few seconds, but all that happens is the voice control screen tries to come on (for a fraction of a second) and then it just goes back to the home screen. It does eventually go to sleep, so it's just the hardware buttons that aren't working.
    And I just took a closer look and there's a very tiny ding on the metal just above (and in the middle area) of the power/sleep button, not sure how long that's been there, but if that's causing the issue why would it also affect the volume buttons on the other side?
  3. sunrisemusic thread starter macrumors member

    Dec 18, 2010
    Okay tried it again after a night's sleep, buttons still not working, but everything else works fine. Any ideas? :confused:


Share This Page