4G touch won't sync photos

Discussion in 'iPod touch' started by Kyle4, Sep 9, 2010.

  1. Kyle4 macrumors 6502

    Aug 14, 2010
    For some reason, my brand new 4G iPod touch does not want to sync photos, it keeps saying there's not enough space even though there is just over 500MB free. I find it funny considering it's only 11 pictures coming in at....3.6mb.

    After the constant rejections it's let me sync more songs, new apps and even iBooks. Yet the measly 3.6mb of photos are a no go. I made a separate folder with just those photos apart from iPhoto and it still doesn't work. Maybe a bug in iOS?
  2. burgundyyears macrumors 6502

    Sep 3, 2010
    Using iTunes 10 in Windows 7, I had no problem just syncing nearly a gigabyte of photos to my 32GB 4G touch. Maybe a mac iTunes issue? Can you get any photos at all to sync?
  3. Kyle4 thread starter macrumors 6502

    Aug 14, 2010
    No, it keeps saying the iPod is full. So far as a workaround I just uploaded the photos to photobucket and saved them to the iPod touch. It's still letting me sync new albums/apps and even videos. I have no idea what its problems with photos are.
  4. djf2010 macrumors newbie

    Sep 19, 2010
    Problem Solved?

    I was having this issue too. That's when I searched google for an answer, and came to this page. As I was goofing around with my new iPod's settings, I checked and unchecked the "Manually Manage Music and Video" box. Fortunately and unfortunately for me, this erased all of the current media on my iPod, but for some reason left the Photo boxes checked. Once the iPod was empty, the iPod added the photos without error, and then I synced the rest of my media after that.

    Long story short, if you erase the rest of your media, and sync the photos first, it should work. If not, I apologize in advance.

  5. Ainze macrumors regular


    Feb 28, 2010
    To offer a different angle, I had the same problem, but the issue was space calculations. Whenever the iPod was sitting there, it thought my music occupied 8.4GB. When I was making changes and it had to calculate the requirements, it reported that music only took 7GB (the correct number, I hasten to add). So, while I had enough space, when it went to actually copy the music over, it went back to thinking 8.4GB and reported not enough space. I had to remove several movies, then sync the photos, then put back most of the movies again.

    Still, anyone else getting transient music reports? I'm kind of tired of losing 1.4GB so randomly.

Share This Page