4hdd/11/40000000 SATA (0,0)?

Discussion in 'MacBook Air' started by Michael Goff, Apr 2, 2013.

  1. Michael Goff macrumors G5

    Michael Goff

    Jul 5, 2012
    Alright, so it started with something as simple as a "service battery" warning. For whatever reason, I decided that this meant "time to use the Apple Hardware Test". When I did, I got that error.

    I checked, and it apparently means I have an SSD error.

    When I looked it up, I found that somebody said "Disk warrior" solved the issue. Is this true? I'd rather not spend money on a program that doesn't actually fix the problem.

    Or should I just take it in while I have the remaining warranty? I don't have an Apple store nearby, merely an authorized repair place, if that makes any difference.
  2. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Take it in, but I recommend you to take a picture of the Error, if they come up with nothing show the Picture and demand a fix, but it will likely show in their better Service Test.

    Have a read here too:

    How to invoke and interpret the Apple hardware tests
  3. Michael Goff thread starter macrumors G5

    Michael Goff

    Jul 5, 2012

    Should I get one with the longer test to make sure nothing goes wrong?
  4. Michael Goff thread starter macrumors G5

    Michael Goff

    Jul 5, 2012
    Update: so, something wasn't installing and somebody on a forum somewhere said I should go into the recovery thing and ran disk repair. I did that, then went to go run the longer check just in case.

    I usually run one and then the other, but this morning I hadn't been able to because of time. I started up the shorter one, since it only takes a couple minutes, and the error is gone. The only thing that it said it fixed has to do with the boot support partition or some such thing.

    I'm confused.
  5. golfleep macrumors newbie

    Feb 19, 2013
    I just got back my 1 month old MBA from the apple store after needing a logic board replacement after it failed to wake up from sleep. I ran the short AHT after I got home and pulled up the same error as you did on the first run of the AHT. Needless to say, I was pretty bummed that I found an error. I did a little more digging, and pulled up the following from apple's site:


    I also booted up from a mountain lion repair USB drive, and repaired the disk permissions of the SSD.

    Afterwards, no errors cropped up on either the regular or extended AHT.

    I'm not sure what it all means, but I'm hoping it's just as Apple stated, in that it's an erroneous alert (even though I was not running the AHT in looping mode)

Share This Page