iPhone 4s big problem - no imei - can not restore - help

Discussion in 'Jailbreaks and iOS Hacks' started by bubi2505, Jan 7, 2015.

  1. bubi2505 macrumors newbie

    Joined:
    Jan 7, 2015
    #1
    Ok, i have a problem... :D

    iphone 4s, working ok until owner changed broken screen. Since then phone can not connect to network, wifi works, but imei is not shown in settings and modem firmware is empty.I guess baseband is broken, maybe that small baseband chip that powers it ?

    Iphone could be used for wifi surfing etc but no phone calls

    Then i tried to restore it and it gave me 3094 error so i tried duf mode restore and it stucks always on apple logo and progress bar at cca 99% while restoring firmware.

    Now it wont even boot, just lights up apple logo for few sec and then turns black.

    How can i restore it? Ios 8,1 is on it and i wonder if there is any custom software which alows restore of ipsw withot flashing baseband , maybe then restore will go to the end then?

    Thanks a lot
     
  2. matthew2926 macrumors 6502

    Joined:
    Sep 13, 2013
    Location:
    Michigan
    #2
    As someone who also replaces iPhone screens, it sounds like whoever did the screen repair forgot to reconnect one or both of the two antenna cables that are inside of the iPhone. This isn't a hard fix but you will need the proper screwdrivers and pry tools. Until this issue is fixed, you won't be able to restore your iPhone or use it in any way. It is also possible that the person broke the antenna(s) in which case they would need to be replaced rather than reconnected. Any local iPhone repair place should be able to handle this if not the person who initially messed up your phone.
     
  3. Natzoo macrumors 65816

    Natzoo

    Joined:
    Sep 16, 2014
    Location:
    Not sure where i am
    #3
    When you do go make sure that you don't leave ur phone signed in, if they ask because i went to one of those iphonerepair places and they stole everything off my phone but fortunately it was a new phone, that had a cracked screen, but just be cautious
     
  4. bubi2505 thread starter macrumors newbie

    Joined:
    Jan 7, 2015
    #4
    Ok, I managed to get this fixed

    I restored iphone with predownloaded ipsw 8.1.2 (using shift+restore) and it gave me error 3 - write verify fail. It took 20 minutes before error showed, it was stuck on apple logo and progress bar up to 99%

    so I found someone's advice to put the phone in the freezer for 30 minutes.

    I was thinking that it is BS but more I read about that more it made sense. Nand memory writes better when cold, if overheated it fails

    I took iphone, wrapped it in paper towel and took a freezer bag, normal plastic bag for freezing food and put it in and left it in freezer for 30 minutes

    When it came out I immediately plugged in cable and restored it (not from dfu) and it went great - fast and successful

    Not everything works

    I even have service once again, phone works great :D
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Nice.
    If that didn't work you could try sticking it inside a plastic rice bag and boiling it for about 10-12 minutes.
    Once done take out and season with salt, pepper and butter:D
     
  6. bubi2505 thread starter macrumors newbie

    Joined:
    Jan 7, 2015
    #6
    lol,i was thinking the same :D

    i had nothing to loose, iphone was bricked anyway

    i got idea from apple forum

    https://discussions.apple.com/thread/5372052?start=360&tstart=0
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Lol:D
    I heard about the freezer trick before too.
    It's funny but it works.
     

Share This Page