4S Jailbreak: NO Phone Icon , No Service

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
Alright, Im on a VZW 32gb 4S, and jailbroke about an hour ago using the OSX method. Everything was working fine, I even made a few calls AFTER the jailbreak.

I tried installing SBsettings, and tried messing with adding it to the Notificnation Center, and all of a sudden I didnt have any service. Went to the homescreen, and noticed that my Phone app is not there anymore.

Can anyone tell me whats wrong? I didnt backup, should I just go through the Jailbreak process again?
 

jredecop

macrumors 6502a
May 20, 2009
588
6
Alright, Im on a VZW 32gb 4S, and jailbroke about an hour ago using the OSX method. Everything was working fine, I even made a few calls AFTER the jailbreak.

I tried installing SBsettings, and tried messing with adding it to the Notificnation Center, and all of a sudden I didnt have any service. Went to the homescreen, and noticed that my Phone app is not there anymore.

Can anyone tell me whats wrong? I didnt backup, should I just go through the Jailbreak process again?
Seems to be a common problem. Mine did it too. I restored and it's all fine now. Using intelliscreenx though. I heard that resetting network settings fixes it. But don't use sbsettings again.

Edit...I set up as new phone.
 
Comment

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
Seems to be a common problem. Mine did it too. I restored and it's all fine now. Using intelliscreenx though. I heard that resetting network settings fixes it. But don't use sbsettings again.

Edit...I set up as new phone.
GOT THE PHONE APP BACK, it was simply disabled in Springtomized2's Capabilities section, but I still have no service?

If I go and re;jailbreak, will I lose info? How do I go about doing it? Just plug the phone in and click Jailbreak again or is there a certain process?
 
Comment

M Quick

macrumors 6502
Nov 9, 2011
418
1
Stockholm, Sweden
GOT THE PHONE APP BACK, it was simply disabled in Springtomized2's Capabilities section, but I still have no service?

If I go and re;jailbreak, will I lose info? How do I go about doing it? Just plug the phone in and click Jailbreak again or is there a certain process?
As you didn't backup prior to first jailbreak, then you have put yourself in a dilemma.. Because if you do a backup now, it will be worthless as in being used as a backup to restore your files, as it will give you the same problem as you are experiencing atm, but it will get all your files back. I'm sure there is a way to save whatever you want to, so i'd advice to google for solutions depending on what kind of files you are looking to save..
 
Comment

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
As you didn't backup prior to first jailbreak, then you have put yourself in a dilemma.. Because if you do a backup now, it will be worthless as in being used as a backup to restore your files, as it will give you the same problem as you are experiencing atm, but it will get all your files back. I'm sure there is a way to save whatever you want to, so i'd advice to google for solutions depending on what kind of files you are looking to save..
Well, the only things it will save is Photos, Apps, and thats it right? I can save the photos, and always re-download the apps right?

I see everyone else re-JBing, can I do it? And how do I do it?
 
Comment

Europa13

macrumors 6502
Feb 1, 2009
379
288
Well, the only things it will save is Photos, Apps, and thats it right? I can save the photos, and always re-download the apps right?

I see everyone else re-JBing, can I do it? And how do I do it?
Everything is saved in the backup (contacts, media, settings, game saves, etc.).

Your apps are still in iTunes on the computer. You simply sync them back on after a restore to factory settings.
 
Comment

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
Everything is saved in the backup (contacts, media, settings, game saves, etc.).

Your apps are still in iTunes on the computer. You simply sync them back on after a restore to factory settings.
My contacts are linked with my gMail account, so those will be saved correct?

I NEED to use my phone, like NOW. Can someone help me out with re-JBing? Why, if I re-JB, does it erase data, when I originally JB it didnt delete any data?
 
Comment

Europa13

macrumors 6502
Feb 1, 2009
379
288
My contacts are linked with my gMail account, so those will be saved correct?

I NEED to use my phone, like NOW. Can someone help me out with re-JBing? Why, if I re-JB, does it erase data, when I originally JB it didnt delete any data?
Yes, your contacts that are backed up in your Gmail account can be synced back on. Rejailbreaking doesn't erase data; restoring to factory settings does. If you are experiencing problems due to the jailbreak, you'll need to restore and then rejailbreak. This is why it's important to do an iTunes/iCloud backup prior to jailbreaking.

Can you access the phone app with Spotlight? Maybe it's just hidden.
 
Comment

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
Yes, your contacts that are backed up in your Gmail account can be synced back on. Rejailbreaking doesn't erase data; restoring to factory settings does. If you are experiencing problems due to the jailbreak, you'll need to restore and then rejailbreak. This is why it's important to do an iTunes/iCloud backup prior to jailbreaking.

Can you access the phone app with Spotlight? Maybe it's just hidden.
I found the Phone app, it was disabled in Springtomization2.

My problem is that I have NO SERVICE. How can I fix this?
 
Comment

jredecop

macrumors 6502a
May 20, 2009
588
6
Did multiple times, just tried to Reset Network Settings and there still 'No Service'.

Should I re-JB?
That is really weird. That has fixed it for most. Did you uninstall sbsettings and try resetting network settings after that?
 
Comment

sddabrow

macrumors 6502
Oct 7, 2011
326
62
No service for me too.. on Sprint.

Seemed to happen after installing SBSettings and then toggling the "3G" tab. Not sure.

I am restoring now and will try to re-jailbreak.
 
Comment

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
That is really weird. That has fixed it for most. Did you uninstall sbsettings and try resetting network settings after that?
Yup, just tried it again in fact, no go. AGHHHHHH I need to use my phone! What should I do? I didnt do a backup, so would Restore to Factory Settings work? And then Re-JB?
 
Comment

jredecop

macrumors 6502a
May 20, 2009
588
6
No service for me too.. on Sprint.

Seemed to happen after installing SBSettings and then toggling the "3G" tab. Not sure.

I am restoring now and will try to re-jailbreak.
This must be a CDMA iPhone 4s thing. That's what broke mine as well. Except with intelliscreenx. After a restore as new and reinstalling intelliscreenx, it works fine! Note though the first time it broke I did have sbsettings installed as well playing with both. I never did the reset network settings thing though cause I didn't know. I just restored my phone and rejailbroke.

----------

Yup, just tried it again in fact, no go. AGHHHHHH I need to use my phone! What should I do? I didnt do a backup, so would Restore to Factory Settings work? And then Re-JB?
You will need to restore and set up as new. Just sync all your photos with iPhoto. You cannot restore from backup unless you did a backup before this all happened.

----------

No service for me too.. on Sprint.

Seemed to happen after installing SBSettings and then toggling the "3G" tab. Not sure.

I am restoring now and will try to re-jailbreak.
Did you try resetting network settings before you did the restore?
 
Comment

sddabrow

macrumors 6502
Oct 7, 2011
326
62
This must be a CDMA iPhone 4s thing. That's what broke mine as well. Except with intelliscreenx. After a restore as new and reinstalling intelliscreenx, it works fine! Note though the first time it broke I did have sbsettings installed as well playing with both. I never did the reset network settings thing though cause I didn't know. I just restored my phone and rejailbroke.

----------



You will need to restore and set up as new. Just sync all your photos with iPhoto. You cannot restore from backup unless you did a backup before this all happened.

----------



Did you try resetting network settings before you did the restore?
I did try resetting network settings and no go. Of course.. I backed it up.. but now it can't find my back up.. weird things always seem to come my way lol
 
Comment

jredecop

macrumors 6502a
May 20, 2009
588
6
I did try resetting network settings and no go. Of course.. I backed it up.. but now it can't find my back up.. weird things always seem to come my way lol
Hey happened to me to. I was impatient with waiting for the restore from my backup and unplugged my phone just to see if my signal was back and that ruined my backup! Oh well.
 
Comment

Tee2eye

macrumors member
Original poster
Aug 20, 2011
36
0
Well, DLing 5.0.1 and restoring through iTunes. Hope this works :(
 
Comment

sddabrow

macrumors 6502
Oct 7, 2011
326
62
Hey happened to me to. I was impatient with waiting for the restore from my backup and unplugged my phone just to see if my signal was back and that ruined my backup! Oh well.
Yeah.. I thought I backed it up.. but maybe it didnt complete?

Just a pain to put all my email addresses, apps, and the settings back to where it was.

Oh well..I will hold off on the JB until this no service thing gets fixed.
 
Comment

0r30

macrumors 6502a
Aug 12, 2010
512
27
Texas
same thing happened to my 4s it went under "no service" after toggling the 3g the problem occured . I reset the network settings then turned off Voice roaming and data roaming and cellular data. then turned them back on and had service back up and running.
 
Comment

pjvedder

macrumors newbie
Jan 20, 2012
1
0
Phone Needs Activation

Tee2eye... this happened to me as well, soon after I installed SBSettings. I did a full restore to factory settings, and nothing. Didn't work. A friend then told me to try calling *228, which brings you to Verizon's automated phone activation service. After you hit 1 to activate, it will put you on hold and activate your phone again. It took a little while after I got off the phone, but eventually you'll get a message saying your phone was activated. Please note I haven't tried this yet WHILE I was jailbroken, but I did it after my factory settings were restored.. either way, it worked and got my phone service back. Pretty scary though for the few hours I was down...

Hope this helps!
 
Comment

smiffer55

macrumors newbie
Jul 28, 2010
26
0
Thank you. Your fix worked for me.
same thing happened to my 4s it went under "no service" after toggling the 3g the problem occured . I reset the network settings then turned off Voice roaming and data roaming and cellular data. then turned them back on and had service back up and running.
 
Comment

Iphone4Swag

macrumors newbie
Oct 10, 2011
8
0
This works! Read and your problem will be solved

Thank you, this was the only thing that worked as I did not want to be at work until 7pm without any service! READ and magic will happen. Thanks again!!!!!

same thing happened to my 4s it went under "no service" after toggling the 3g the problem occured . I reset the network settings then turned off Voice roaming and data roaming and cellular data. then turned them back on and had service back up and running.
 
Comment

adamant628

macrumors newbie
Jan 21, 2012
3
0
same thing happened to my 4s it went under "no service" after toggling the 3g the problem occured . I reset the network settings then turned off Voice roaming and data roaming and cellular data. then turned them back on and had service back up and running.

This fix worked for me! Thanks, I'd already restored once, then reinstalled SBSettings and did it again.

I used it several times before toggling the 3G button the first time, so it was very tough to narrow down what I had done to mess things up. Resetting network settings didn't do it by itself, but toggling the cellular data and roaming worked!

I tried to replicate it again, and simply toggling the cellular data and voice roaming buttons was sufficient. Resetting network settings was not necessary.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.