4s Wifi antenna

Discussion in 'iPhone Tips, Help and Troubleshooting' started by bnqcsac, Mar 29, 2014.

  1. bnqcsac macrumors newbie

    Joined:
    Mar 29, 2014
    #1
    Is there any way to do a qualitative test on my phone's wifi antenna?

    I've been having issues connecting to wifi lately. I can only maintain a connection when I'm basically on top of my access point. I can't be for sure, but the problem may have coincided with a recent hard drop of the phone.

    In my home, my AP is the only one that shows up on the available networks when prior to this i could pick up a half dozen or more of the neighbor's.

    Despite showing "full bars", I usually get an "unable to join" error just selecting it, otherwise I'll get the error after I try entering my credentials.

    I took my phone to the geniuses, just to make sure it wasn't s/w related because the timing was about the 7.1 upgrade date. but the genius had no problem connecting - i suspect because the retail stores are blasted with wall to wall wifi.

    the genius saw some safari errors regarding memory overflows that he suspected were causing the issue and recommended doing a hard reinstall of the phone. I had already did that, but the genius though that i was just reinstalling the problem when i restored from my backup.

    Anyways, tried again today and no dice.

    Could I have partially damaged my antenna? maybe busted one of the solders, for example?

    Thanks for any help.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Yep, sounds like the antenna might have gotten loose from the drop and thus the wifi issues.
     

Share This Page