4s wifi chip must be hosed? any options

Discussion in 'iPhone' started by ematsui, Jul 15, 2014.

  1. ematsui macrumors member

    Joined:
    Aug 12, 2009
    #1
    So I have a couple year old iPhone 4s that is in real good shape. It was my wife's old phone that we gave to our daughter to use as a iPod touch (no cellular).

    All of a sudden (maybe after ios7.x) it cannot connect to any wifi network. It can see the networks and scan them, but when it tries to connect it just says unable to join. If I look a the logs in my router, there is no evidence that it even tried to connect.

    I have reset network settings, restored as new, upgraded to the latest OS, etc

    Took it to work and tried to hook it up to our many wifi spots and get the same issue.

    Is the chip just dead..? anything I can do to bring it back to life or is it pretty much a useless device now. Can really only listen to music by syncing it via usb cable.
     
  2. Jaguarr40 macrumors regular

    Jaguarr40

    Joined:
    Jul 10, 2014
    Location:
    Sarasota, Florida
    #2
    Try 2 things... First off reboot your router with the phone nearby and also if it can scan and pick up after that or it has WIFI spots already in the pnone tap the i in the circle and hit "Forget This" and then close it and try again and see what that does. There should be no reason for it to not see your router unless you have a setting in your router turned off. So reboot and then open your router through your browser and look at the settings.
     

Share This Page