4s wifi issues on authenticated hotspots

Discussion in 'iOS 6' started by liteshow, Sep 21, 2012.

  1. liteshow macrumors regular

    Joined:
    Sep 20, 2012
    #1
    I have a 4s with ios6. I know there were earlier Wifi issues and lots of complaints on the first day of iso 6 release but Apple "resolved it" by fixing their website. However, I am still experiencing an issue which I think is related to having a limited "data plan" with my carrier Speakout and a authenticated hotspot. The "data plan" only allows port 80 and 443, so works for browsing and most apps. Of course some features won't work on 3G which I can live with.

    My work place has a Wifi hotspot that required you to authenticate to access (an extra step of security). While still on ios 5.1.1, I can walk into workplace, fire up a browser and be redirected to login page to authenticate and then I am connected via wifi.

    After ios 6 upgrade, Wifi is not connecting. When I manually try to connect, it will try to get to the login page automatically and fail with the error " Hotspot login cannot open the page because it could not establish a secure connection to the server". Tried resetting, forgetting networks, etc, but could not work.

    However I found a TEMPORARY FIX: Turn off 3G first, connect wifi, authenticate and login and then re-enable 3G.

    I think when attempting to connect to authenticated wifi with 3G on, ios 6 tries to send something via Speakout's 3G on a unsupported port (not 80 or 443) and fails, and then it gives up and refuses to connect to the wifi authenticated login page. So an extra step for me.

    Anyone else experience the same issue?
     
  2. R4z3r macrumors member

    Joined:
    Jan 19, 2009
    Location:
    NJ
    #2
    I get the same basic issue. But for me it let's me connect after authenticating but continuously drops the Wi-Fi connection making the fact that I'm "connected" useless.
     
  3. Zimmy68 macrumors 65816

    Zimmy68

    Joined:
    Jul 23, 2008
    #3
    I am having this issue with both my iPad and iPhone.
    The only thing that works for me is rebooting the device.
    Nt sure why this isn't a front page issue.
    My wifi shows connected but no websites can be reached.
     
  4. hunterfreeman1 macrumors newbie

    Joined:
    Apr 7, 2011
    #4
    im still having this same issue i can connect at home but while out of town this weekend i couldn't connect to either the att free WiFi or the hhonors (Hilton honors) network where i was staying. Today wen i got into work it wont connect either. my WiFi toggle works and i see my work ssid but when i click to try to connect and enter my network key it just says unable to connect to "my ssid" and then gives me a button to dismiss the prompt.
     
  5. liteshow thread starter macrumors regular

    Joined:
    Sep 20, 2012
    #5
    Just curious, have you tried disabling your Cellular data first and then connecting wifi? I have to do that for mine.
     
  6. hunterfreeman1 macrumors newbie

    Joined:
    Apr 7, 2011
    #6
    yes i have tried everything restoring the phone and the router to factory defaults updating the firmware on my router changing my ssid changing my paskey nothing seems to work
     
  7. pjarvi, Sep 25, 2012
    Last edited: Sep 25, 2012

    pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #7
    I wasn't having a problem with an error page, but was having a problem that when I woke up my 4S and went to access anything that used data it was not prompting me to reconnect to the local Wi-Fi (same setup where I have to accept a EULA before it will authenticate), instead it was just using 3G (Verizon).

    To fix it all I did was turn on the "Ask to Join" option in the Wi-Fi settings. Now it prompts me perfectly each time I wake the phone up.

    Wifi.jpg
     

Share This Page