4th gen iPod touch minor issues - help requested

Discussion in 'iPod touch' started by Lloydbm41, Oct 17, 2013.

  1. Lloydbm41 macrumors 68040

    Lloydbm41

    Joined:
    Oct 17, 2013
    Location:
    Central California
    #1
    Hoping someone can help me out here. I did a search, but came up empty for my particular issue.
    I have a 4th gen touch that is in perfect condition, and used primarily for music in the car and for working out/running with the Nike Run app and syncing with the Nike+ Fuelband. Everything works, no issues there, but here are my two (albeit minor) issues.

    1. When I start some, not all, apps. They force close on me after about a minute and I get sent back to the homescreen. This can be extremely infuriating when I have started a run with the Nike app and none of my data gets recorded. Mind you, the app started everything was fine, but a minute or two in, it just stops. This happens on just a few apps and only randomly, not every time.
    2. Most apps and menu screens are zippy. But when I click some apps, I get up to a 10 second delay. It is very, very strange. I can post a video if it would be helpful?

    Solutions I have tried:
    1. Went to the Apple store and they reset everything for me to stock.
    2. I reset the iPod to stock myself. Set it to newest version of ios6, since I can't install ios7.
    3. I uninstalled and reinstalled iTunes. Latest version of iTunes installed.
    4. Only installed the apps I use, plus music. I have over 10gb of free space available.

    Not sure what else to do? These are minor inconveniences, sure, but if anyone has advice, I am all ears. And yes, I know I am using an older iPod (2 years old), but like I said, it has never been abused, always in a case or my armband for workouts, etc, so it is in pristine condition. I don't want to have to buy a new iPod. I hope I am simply overlooking something minor, so a fresh perspective is appreciated. Thanks.
     
  2. eRondeau macrumors 6502a

    eRondeau

    Joined:
    Mar 3, 2004
    Location:
    Canada's South Coast
    #2
    A few thoughts...

    • Is there pocket lint or other crud on your dock connector pins? That can cause all sorts of bizarre effects. Take a piece of good paper, fold it over, and carefully clean the inside of the dock connector and especially the pins. Then gently blow all the crud out. It's surprising how much gets in there.
    • Did you restore your iPod from within iTunes? I'd recommend wiping it clean and re-downloading & installing all your apps from scratch. It's possible that iTunes backed-up a bad app, which keeps getting re-installed.
    • Check your Crash Log, it'll list the apps that crashed and summarize why. Look for Low Memory crashes especially. Despite having 10GB free, your 4G only has 256MB of RAM -- half what the 5G has. Maybe it just ain't enough, especially if you're running the Nike app in the background.

    Good luck!
     
  3. defunct32 macrumors regular

    Joined:
    Jul 19, 2013
    #3
    4th gen iPod touch minor issues - help requested

    iOS 6.1.3 runs terrible on a 4th Gen iPod (my nephew has one), have you tried to only just switch off the iPod and let it rest for a few minutes and then power it on again? This will free up all RAM on the iPod so apps run more smoothly, there was no real need to reset the device to stock or re-installing iTunes. The 4th Gen has only 256 MB worth of RAM so it's not much.
     
  4. Lloydbm41 thread starter macrumors 68040

    Lloydbm41

    Joined:
    Oct 17, 2013
    Location:
    Central California
    #4
    Thank you for the input guys. Yes, I have tried clearing the RAM. I have also just attempted to run a single program (Nike Run) in this case and it makes no difference. I simply can't figure out why only a few apps seem to be affected? I have cleaned out the input port as well, but no difference. Next step is what you listed in both 2 and 3 on your list eRondeau.

    If the issue remains I'll just have to live with the minor inconvenience. It's not a show stopper and eventually I will upgrade to a newer device running iOS7. Just not att.

    I appreciate both responses above. Thanks guys.
     
  5. defunct32 macrumors regular

    Joined:
    Jul 19, 2013
    #5
    Let us know how it goes!
     
  6. SusanK macrumors 68000

    Joined:
    Oct 9, 2012
    #6
    Mine does this sometimes on iOS 5.1.1. I quit all apps except the one I am using. Seems to do the trick for the app crashes. As to the lag it's there with OS 5.

    My iPod Touch 4g with iOS 6 does not lag.
     
  7. Lloydbm41 thread starter macrumors 68040

    Lloydbm41

    Joined:
    Oct 17, 2013
    Location:
    Central California
    #7
    I'm on the last update possible for the 4th gen iPod Touch (iOS 6.1.3). I have also turned off every single feature I can think of, to ensure least amount of RAM used in the baackground, turned off all iCloud syncing, auto-downloading of apps off, and so on.
    Reinstalled everything again via a fresh iTunes load as well. Looks like some apps just take a while to load. Maybe I am just used to a lot faster processors in newer devices is all. My iPod does the job, so I'm just gonna leave it be and use it.

    Thanks again to everyone taking the time to respond. Cheers.
     

Share This Page