5.1 Audio Out via HDMI Help

Discussion in 'Digital Audio' started by Ratboy, Dec 12, 2014.

  1. Ratboy macrumors member

    Joined:
    Feb 2, 2002
    #1
    My Mac mini is connected to my Vizio M-Series TV using an HDMI cable, and the TV is connected to a Vizio 5.1 sound bar with an optical cable. Since the TV (which has stereo speakers) is first in the chain, the Mac downgrades a 5.1 signal to 2.0 despite the fact that the TV is passing the signal on to a surround sound-capable system.

    I have been on the phone for a long time with both Apple and Vizio, and there isn't a solution to the problem that either of them can offer. The TV can't report that it is capable of handling a 5.1 signal, and there's no way to force the computer to send one.

    Are there any method for getting 5.1 audio to play?
     
  2. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #2
    Toslink cable out of the audio socket of the mac?

    That's what I'm using for the 2009 mini as it doesn't support audio over HDMI.
     
  3. Ratboy thread starter macrumors member

    Joined:
    Feb 2, 2002
    #3
    Should a cable like this work? I'm surprised that the computer can output a 5.1 signal through the 3.5mm stereo jack.
     
  4. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #4
    Yes that is it. Also it's not just a 3.5mm Stereo jack. It is a combination jack that supports 3.5mm stereo analog out and optical S/PDIF digital out.
     
  5. Ratboy thread starter macrumors member

    Joined:
    Feb 2, 2002
    #5
    I have the TosLink cable, and in the Sound preference pane, the name of the device for sound output is now "Digital Out". However, when I go into Audio Midi Setup, the Built-In Output shows "0 in/2 out", and if I click the Configure Speakers button, I only have the option to choose "Stereo" from the Multichannel pull-down menu (regardless of the Format I choose).

    Is there something else I should be doing?

    Thanks for the help.
     
  6. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #6
    You'll need to enable passthrough/bitstreaming for the digital out in the application. I'm not aware of a system wide setting.

    I mainly use XBMC (now Kodi) and VLC also supports it.
     
  7. Ratboy thread starter macrumors member

    Joined:
    Feb 2, 2002
    #7
    Would you explain this in a bit more depth? I use Plex and VLC, and I don't see any passthrough/bitstreaming option.

    It also seems to me that despite a specific application setting, the Mac thinks the receiver is only 2.0 and downgrades any audio regardless of the application.

    Thanks.
     
  8. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #8
    VLC - Audio Menu, then Audio Device. Select Built in Output (Encoded Output).

    Plex will do it, but I uninstalled it a while back.
     
  9. Ratboy thread starter macrumors member

    Joined:
    Feb 2, 2002
    #9
    Thank you. It works.
     

Share This Page