500 Gb USB Iomega drive no longer mounts

Discussion in 'Mac Accessories' started by stockychaser, May 25, 2009.

  1. stockychaser macrumors newbie

    Joined:
    May 25, 2009
    Location:
    Belgium
    #1
    setup : 2x iMac 24" 10.5.6..wired to airport Xtreme, Iomega 500 GB HD connected via USB

    this drive worked fine and has all the pics on it and was used to backup both iMac's via Time Machine.
    Today the Airport Xtreme (AX) gives us a flashing orange light and informs us that the 500 GB Iomega disk needs to be connected to the mac and needs to be repaired.

    so...we did, with a "disk appears to be OK " message after 'repair'
    mounting from within Disk Utility gives us : "The disk “500HD” could not be mounted.
    Try running First Aid on the disk and then retry mounting."
    (we did just that...!)

    We also tried "Drive Genius" with the same results.

    whether we hook the drive to the AX or directly to the iMac...no mounting.
    The drive (and it's partition) does appear perfectly in both 'Disk Utility' and in 'Drive Genius'

    (The iMac does mount other USB items like mem-sticks, camera's just fine.)

    anybody any ideas how to get this working again ?
    thanks !
     
  2. stockychaser thread starter macrumors newbie

    Joined:
    May 25, 2009
    Location:
    Belgium
    #2
    hooked the drive up to another iMac with 10.5.7 and here... disk repair gave me a
    "volume header needs a minor repair"

    ...after repair, I did another repair disk again and Disk Utilities said the drive was OK....
    though...
    still UNABLE TO MOUNT DRIVE when trying to mount the drive.
     

Share This Page